
Sun Microsystems, Inc.
901 San Antonio Road
Palo Alto, CA 94303-4900 U.S.A.
650-960-1300

Send comments about this document to: docfeedback@sun.com

SunForum 3.2 Software User’s
Guide

Part No. 816-1114-10
April 2001, Revision A



Please
Recycle

Copyright 2001 Sun Microsystems, Inc., 901 San Antonio Road • Palo Alto, CA 94303 USA. All rights reserved.

This product or document is protected by copyright and distributed under licenses restricting its use, copying, distribution, and decompilation.

No part of this product or document may be reproduced in any form by any means without prior written authorization of Sun and its licensors,

if any. Third-party software, including font technology, is copyrighted and licensed from Sun suppliers.

Parts of the product may be derived from Berkeley BSD systems, licensed from the University of California. UNIX is a registered trademark in

the U.S. and other countries, exclusively licensed through X/Open Company, Ltd.

Sun, Sun Microsystems, the Sun logo, Sun Ray, Ultra, ShowMe, Sun Workstation, AnswerBook2, SunForum, and Solaris are trademarks, registered

trademarks, or service marks of Sun Microsystems, Inc. in the U.S. and other countries. All SPARC trademarks are used under license and are

trademarks or registered trademarks of SPARC International, Inc. in the U.S. and other countries. Products bearing SPARC trademarks are

based upon an architecture developed by Sun Microsystems, Inc. PostScript is a trademark of Adobe Systems Incorporated, which may be

registered in certain jurisdictions. For SunForum 3.2, the following notice applies: Copyright DATA CONNECTION LIMITED 2001 Copyright

TELES AG 2001 DATA CONNECTION® is a registered trademark of DATA CONNECTION LIMITED in the U.S. and other countries.

The OPEN LOOK and Sun™ Graphical User Interface was developed by Sun Microsystems, Inc. for its users and licensees. Sun acknowledges

the pioneering efforts of Xerox in researching and developing the concept of visual or graphical user interfaces for the computer industry. Sun

holds a non-exclusive license from Xerox to the Xerox Graphical User Interface, which license also covers Sun’s licensees who implement OPEN

LOOK GUIs and otherwise comply with Sun’s written license agreements.

Federal Acquisitions: Commercial Software—Government Users Subject to Standard License Terms and Conditions.

DOCUMENTATION IS PROVIDED “AS IS” AND ALL EXPRESSED OR IMPLIED CONDITIONS, REPRESENTATIONS AND

WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE

OR NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE

LEGALLY INVALID.

Copyright 2001 Sun Microsystems, Inc., 901 San Antonio Road • Palo Alto, CA 94303 Etats-Unis. Tous droits réservés.

Ce produit ou document est protégé par un copyright et distribué avec des licences qui en restreignent l’utilisation, la copie, la distribution, et la

décompilation. Aucune partie de ce produit ou document ne peut être reproduite sous aucune forme, par quelque moyen que ce soit, sans

l’autorisation préalable et écrite de Sun et de ses bailleurs de licence, s’il y en a. Le logiciel détenu par des tiers, et qui comprend la technologie

relative aux polices de caractères, est protégé par un copyright et licencié par des fournisseurs de Sun.

Des parties de ce produit pourront être dérivées des systèmes Berkeley BSD licenciés par l’Université de Californie. UNIX est une marque

déposée aux Etats-Unis et dans d’autres pays et licenciée exclusivement par X/Open Company, Ltd.

Sun, Sun Microsystems, le logo Sun, Sun Ray, Ultra, ShowMe, Sun Workstation, AnswerBook2, SunForum, et Solaris sont des marques de fabrique ou

des marques déposées, ou marques de service, de Sun Microsystems, Inc. aux Etats-Unis et dans d’autres pays. Toutes les marques SPARC sont

utilisées sous licence et sont des marques de fabrique ou des marques déposées de SPARC International, Inc. aux Etats-Unis et dans d’autres

pays. Les produits portant les marques SPARC sont basés sur une architecture développée par Sun Microsystems, Inc. PostScript est une

marque de fabrique d’Adobe Systems, Incorporated, laquelle pourrait être déposée dans certaines jurisdictions. La notice suivante est

applicable à SunForum 3.2 : Copyright DATA CONNECTION LIMITED 2001 Copyright TELES AG 2001 DATA CONNECTION® est une

marque déposée de DATA CONNECTION LIMITED aux Etats-Unis et dans d’autres pays.

L’interface d’utilisation graphique OPEN LOOK et Sun™ a été développée par Sun Microsystems, Inc. pour ses utilisateurs et licenciés. Sun

reconnaît les efforts de pionniers de Xerox pour la recherche et le développement du concept des interfaces d’utilisation visuelle ou graphique

pour l’industrie de l’informatique. Sun détient une licence non exclusive de Xerox sur l’interface d’utilisation graphique Xerox, cette licence

couvrant également les licenciés de Sun qui mettent en place l’interface d’utilisation graphique OPEN LOOK et qui en outre se conforment aux

licences écrites de Sun.

CETTE PUBLICATION EST FOURNIE "EN L’ETAT" ET AUCUNE GARANTIE, EXPRESSE OU IMPLICITE, N’EST ACCORDEE, Y

COMPRIS DES GARANTIES CONCERNANT LA VALEUR MARCHANDE, L’APTITUDE DE LA PUBLICATION A REPONDRE A UNE

UTILISATION PARTICULIERE, OU LE FAIT QU’ELLE NE SOIT PAS CONTREFAISANTE DE PRODUIT DE TIERS. CE DENI DE

GARANTIE NE S’APPLIQUERAIT PAS, DANS LA MESURE OU IL SERAIT TENU JURIDIQUEMENT NUL ET NON AVENU.



Contents

Preface xi

1. Introduction to SunForum 1

SunForum Features 1

Online Help 2

2. Using SunForum 3

SunForum Basics 3

▼ To Start the SunForum Software 3

SunForum Menus 5

Using Directories 9

▼ To Change Your Directory Information 9

▼ To Log In to a Directory Server 10

▼ To Log Out From a Directory Server 10

▼ To Refresh the Directory List 10

▼ To Automatically Log In to a Directory Server at Startup 10

▼ To Remove Your Name From the Directory Server 11

▼ To Call a User in the Directory List 11

▼ To Call a User on a Directory Server Using an Email Address 11

Using the SunForum Software 12
iii



Using the SunForum Audio and Video 16

Using the SunForum Whiteboard 24

▼ To Select a Whiteboard Mode 24

▼ To Start the Whiteboard 25

3. SunForum Phone 37

Starting the SunForum Phone 37

SunForum Phone Menus 39

Using the SunForum Phone 41

My Video 43

Audio and Video Device Settings 44

Media Configuration Wizard 45

Preferences 46

4. Configuring Gateway Software 47

Overview 47

Gateway Configuration File 47

Using SunForum Phone Gateway 49

5. SunForum on a Sun Ray System 51

Sun Ray Requirements 51

Sun Gatekeeper Software 52

6. Technical Information 55

SunForum Architecture 55

SunForum’s Conferencing Topology 56

SunForum’s Whiteboard and Compatibility Mode 57

Using the SunForum Software Through a Network Security Mechanism 58

Using TrueType Fonts With SunForum Software 59

Calling Into a Multipoint Control Unit 59
iv SunForum 3.2 Software User’s Guide • April 2001



Calling Into Password-Protected Conferences 60

Optimizing Video Display 60

Solving Color Problems 60

SunForum Software Support 61
Contents v



vi SunForum 3.2 Software User’s Guide • April 2001



Figures

FIGURE 2-1 My Information Window 4

FIGURE 2-2 SunForum 3.2 Conference Manager 5

FIGURE 2-3 Conference Manager Audio and Video Icons 17

FIGURE 2-4 SunForum 3.2 Whiteboard 25

FIGURE 2-5 Whiteboard Tool Panel 26

FIGURE 2-6 Whiteboard Options Button 27

FIGURE 2-7 Whiteboard Options Panel 27

FIGURE 2-8 Rubber Stamps Button 32

FIGURE 2-9 Whiteboard Stamps Window 32

FIGURE 2-10 New Page Button 34

FIGURE 2-11 Print Button 35

FIGURE 3-1 SunForum Phone 38

FIGURE 3-2 Placing a Call 42

FIGURE 3-3 SunForum Phone Preferences Window 46

FIGURE 4-1 SunForum Phone GUI in Gateway PBX Mode 48

FIGURE 4-2 Gateway Network Example of Systems Running SunForum 3.2 49

FIGURE 4-3 Gateway Mode 50

FIGURE 6-1 T.120 Conference Hierarchy 57
vii



viii SunForum 3.2 Software User’s Guide • April 2001



Tables

TABLE 2-1 Call Menu 6

TABLE 2-2 View Menu 6

TABLE 2-3 Tools Menu 7

TABLE 2-4 Options Menu 8

TABLE 2-5 Audio and Video Options 18

TABLE 2-6 Audio and Video Device Options 19

TABLE 2-7 Whiteboard Menu Bar Descriptions 26

TABLE 3-1 Call Menu 39

TABLE 3-2 Controls Menu 40

TABLE 3-3 Address Book Menu 40

TABLE 3-4 Audio and Video Settings 43

TABLE 3-5 Audio and Video Device Options 44

TABLE 3-6 Media Configuration Wizard 45

TABLE 3-7 SunForum Phone Preferences 46
ix



x SunForum 3.2 Software User’s Guide • April 2001



Preface

This manual describes how to install and use the SunForum™ collaboration software

with your Sun™ system. It is for users who want to collaborate over intranets and

the internet with both UNIX® and PC-based participants through data conferencing.

How This Book Is Organized

Chapter 1 describes the SunForum product.

Chapter 2 describes how to use the SunForum product, including audio and video

features and the SunForum Whiteboard.

Chapter 3 describes the SunForum 3.2 phone feature.

Chapter 4 describes the SunForum gateway access.

Chapter 5 describes using SunForum on a Sun Ray™ system.

Chapter 6 provides technical information about the SunForum software.
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Using UNIX Commands

This document does not contain information on basic UNIX commands and

procedures such as shutting down the system, booting the system, and configuring

devices.

See one or more of the following for this information:

■ Solaris Handbook for Sun Peripherals

■ AnswerBook2™ online documentation for the Solaris™ 2.x operating

environment

■ Other software documentation that you received with your system

Typographic Conventions

Typeface Meaning Examples

AaBbCc123 The names of commands, files,

and directories; on-screen

computer output.

Edit your .login file.

Use ls -a to list all files.

% You have mail .

AaBbCc123 What you type, when

contrasted with on-screen

computer output.

% su
Password:

AaBbCc123 Book titles, new words, or

terms; words to be emphasized;

command-line variable: replace

with a real name or value.

Read Chapter 6 in the User’s Guide.

These are called class options.

You must be root to do this.

To delete a file, type rm filename.
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Shell Prompts

Accessing Sun Documentation Online

The docs.sun.com sm web site enables you to access a select group of Sun technical

documentation on the Web. You can browse the docs.sun.com archive or search

for a specific book title or subject at:

http://docs.sun.com

Ordering Sun Documentation

Fatbrain.com, an Internet professional bookstore, stocks select product

documentation from Sun Microsystems, Inc.

For a list of documents and how to order them, visit the Sun Documentation Center

on Fatbrain.com at:

http://www.fatbrain.com/documentation/sun

Shell Prompt

C shell %

C shell superuser #

Bourne shell and Korn shell $

Bourne shell and Korn shell

superuser

#

Preface xiii



Sun Welcomes Your Comments

Sun is interested in improving its documentation and welcomes your comments and

suggestions. You can email your comments to Sun at:

docfeedback@sun.com

Please include the part number (816-1114-10) of your document in the subject line of

your email.
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CHAPTER 1

Introduction to SunForum

SunForum 3.2 software is a conferencing product for Sun computer systems. It is

based on the T.120 and H.323 standards, which enables your Sun system to

conference over intranets and the Internet with other T.120 and H.323 products.

SunForum Features

SunForum 3.2 software features:

■ View and control applications shared from other UNIX or PC machines that are

based on the T.120 protocol

■ Share local Solaris applications, which can be viewed and controlled by any

conference participant

■ Exchange ideas and data using the whiteboard, clipboard, chat, and file transfer

facilities

■ Use audio and video communications via the H.323 protocol

■ DTMF tone generation, in-band and out-of-band through H.245 protocol

■ Testing and workarounds for ambiguously specified Voice-over IP (VoIP) and

H.323 equipment

■ New SunForum Phone GUI

■ Ability to automatically place calls through a gateway

■ Sun Gatekeeper

■ Lightweight Directory Access Protocol (LDAP) server configuration tool

■ G.729a audio encoding
1



Online Help

You can read information about the SunForum software online by accessing help

from the Help menu located on any SunForum menu bar.
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CHAPTER 2

Using SunForum

This chapter contains the following topics:

■ “SunForum Basics” on page 3

■ “Using Directories” on page 9

■ “Using the SunForum Software” on page 12

■ “Using the SunForum Audio and Video” on page 16

■ “Using the SunForum Whiteboard” on page 24

SunForum Basics

▼ To Start the SunForum Software

● After installing SunForum 3.2 software packages, type the following at your
system prompt:

Note – If the SunForum directory is not set in your path, type the correct path name

(for example, /opt/SUNWdat/bin/sunforum ).

The SunForum conference manager is displayed. When you start SunForum for the

first time, however, the My Information window is displayed.

% sunforum
3



FIGURE 2-1 My Information Window

● Type your name and email address in the My Information window.

Note – You must type your name and email address. You cannot collaborate unless

this minimum information is entered.

The next time you start the SunForum software, the My Information window will

not display automatically. However, you can change the information in the My

Information window anytime by choosing Call ➤ Change My Information to open

the information window.

When completing the My Information window, the Configuration Wizard window is

displayed for configuring audio/video.

When complete, the SunForum conference manager is displayed as the active

window.

(new image that
shows
SunForum Name
and SunForum
Number is
required)
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FIGURE 2-2 SunForum 3.2 Conference Manager

SunForum Menus

There are five menus on the SunForum menu bar: Call, View, Tools, Options, and

Help.

Note – You can also use the SunForum conference manager buttons to access most

of the functions in the Call, View, and Tools menus. See “Using the SunForum

Software” for more information.
Using SunForum 5



Call Menu

View Menu

Use the View buttons to change these listings viewed in the SunForum conference

manager.

TABLE 2-1 Call Menu

Menu Description

Place Call To place a call to an indicated address. You can also click the

Call button.

Stop Placing Call To cancel an in-progress call request.

Host Conference To start a conference.

Hang Up To end your call. (Same as clicking the Hang Up button.)

Do Not Disturb To block incoming calls. You may, however, call out.

Create SpeedDial To create speed dial files for use in your address book or for

exchange with other users.

Run In Background To allow SunForum to continue running in the background

when you exit.

Log On To Directory

Server

To log in to a directory server. You will be prompted for the

server name.

Change My Information To make changes to your profile information.

Address listing To call recently accessed addresses.

Exit To exit or place in background the current SunForum session.

TABLE 2-2 View Menu

Menu Item Description

Compact View To turn the Conference Manager into menu bar.

Always On Top To cause the Conference Manager window to always be on top.

Directory To view the directory server. It lists who you can conference with.

Address Book To display addresses that you have conferenced with and added to

your address book.

Call Status Use during a call to view the status of conference participants and

the status of the application sharing, whiteboard, and chatting

features.
6 SunForum 3.2 Software User’s Guide • April 2001



Note – To remove an item from the Address Book and History lists, select the item

and press the Delete key.

Tools Menu

History To list the status of received calls.

Refresh Directory To query the directory server for an immediate update of the

directory listings.

Call Information To view audio/video bandwidth usage in the current call.

TABLE 2-3 Tools Menu

Menu Item Description

Switch Audio and

Video

To switch audio and video to another participant. Present only

while in a conference.

Video To select video windows to be displayed.

Configuration

Wizard

To start the Configuration Wizard program.

Share Application To share your applications with others on the call. A submenu lists

the shareable applications you have running on your desktop.

Share To select an application window on your desktop for sharing. (Same

as clicking the Share button.)

Unshare To unshare the application. (Same as clicking the Unshare button.)

Collaborate To shift a shared application from view-only to collaborate. When

you collaborate an application, you enable others to take control of

the application. (Same as clicking the Collaborate button.)

Send File To select a file to send to everyone in the conference. (Same as

clicking the Send button.)

Cancel All Sends To cancel sending of files.

Cancel All Receives To cancel receipt of files.

Shared Desktop

Viewer

To show an overview of all user desktops and the location of shared

applications.

TABLE 2-2 View Menu (Continued)

Menu Item Description
Using SunForum 7



Options Menu

Help Menu

You can access help from the Help menu, located on the SunForum menu bar.

Choose Help ➤ Help Topics for online SunForum information.

Note – The Help Topics menu is on each of the SunForum window menu bars.

Whiteboard To start the whiteboard graphical application. The whiteboard

automatically starts on other user systems in the conference. (Same

as clicking the Whiteboard button.)

Chat To start the chat application. The chat window automatically starts

on other user systems in the conference. (Same as clicking the Chat

button.)

Share Clipboard To copy and paste clipboard data between systems.

TABLE 2-4 Options Menu

Menu Item Description

Call Settings To configure SunForum options for handling calls.

Tool Settings To configure general SunForum options.

Audio/Video

Settings

To configure audio/video conference attributes.

Audio/Video Device

Settings

To configure the audio input and output devices and video input

device, including the Sun Ray and Sun 1394 Camera.

TABLE 2-3 Tools Menu (Continued)

Menu Item Description
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Using Directories

To setup your directory entry, you must specify your own details, including name,

location, and email address. You are prompted for these details the first time you run

SunForum. You can choose whether to list these details for access by everyone; if

you do not, then only those people who know your email address will be able to call

you via the directory.

This section contains the following topics:

■ To Change Your Directory Information

■ To Log In to a Directory Server

■ To Refresh the Directory List

■ To Automatically Log In to a Directory Server at Startup

■ To Remove Your Name From the Directory Server

■ To Call a User in the Directory List

■ To Call a User on a Directory Server Using an Email Address

▼ To Change Your Directory Information

1. Choose Call ➤ Change My Information.

2. Fill in the following fields:

■ First Name and Last Name . This is the name used to identify you in a

conference.

■ E-mail address . This is used to identify you when you are logging in to a

directory server.

■ SunForum Name and SunForum Number . SunForum users, especially those

using the product for the first time, need to be aware that the "SunForum Name"

and "SunForum Number” need to be unique. The Directory Server currently has

no way to otherwise uniquely identify users as they are logged onto the server.

Additionally, there is no connection between these entities and a person’s system

username, office telephone number, and so on. However, users can choose to

make their SunForum Name identical to their username, and their SunForum

Number identical to their office phone extension, if they wish.

It is important to remember that, when using the "standard" mode of placing a

SunForum call, the number used in the call is the SunForum Number as entered

in the call recipient’s SunForum user information. By contrast, entering a number

when placing a call via the gateway will attempt to make a connection over the
Using SunForum 9



local telephone system, if the SunForum system configuration is setup to do so.

This distinction is important to remember when placing calls to a recipient whose

SunForum and office telephone numbers are identical.

■ Category . This is used by servers to narrow down the list of names when

querying or choosing a directory server.

3. Change the details as required and click OK.

▼ To Log In to a Directory Server

1. To view the directory listing, choose Call ➤ Log On To Directory Server.

2. Type the name of the directory server you want to log in to and click OK.

When SunForum has successfully logged in to the directory server, the server is

automatically queried for other users also logged in to that directory.

▼ To Log Out From a Directory Server

● To log out from a directory server, choose Call ➤ Log Off From Directory Server.

Note – You can configure an LDAP server as a SunForum directory server. To do

this, refer to the SunForum 3.2 Help for these system administrator procedures.

▼ To Refresh the Directory List

● Choose View ➤ Refresh Directory.

This option can be selected only when the directory list is displayed.

▼ To Automatically Log In to a Directory Server at

Startup

1. Choose Call ➤ Change My information.

2. Select “At startup, log on to the directory server.”

3. Specify the directory server name in the Server Name field.
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4. Type the name of the directory server you want to log in to in the Server Name
field.

The next time you start SunForum, it will log in to the directory server you specified.

▼ To Remove Your Name From the Directory

Server

1. Choose Call ➤ Change My Information.

2. Select “Do not list my name when logged on to the directory server.”

The next time you log in to a directory server, your name and details will not be

visible to users browsing the directory.

If you are currently logged in and your name is displayed when you select this

option, SunForum automatically updates your entry at the directory server so that

your name is not displayed.

▼ To Call a User in the Directory List

To call a user shown in the directory list, double-click that entry in the directory

view.

Note – If “Add to address book” in the Place Call window (Call ➤ Place Call) is

selected, any users you call via the directory list will be added to the address book

list.

▼ To Call a User on a Directory Server Using an

Email Address

The SunForum software enables you to call a user who is logged in to a directory

server by specifying the user’s email address.

● Type the name of the directory server the user is logged in to and the user email
address, separated by a slash (/).

The SunForum software queries the specified directory server for a user with the

email address you entered. If the user is logged in to the directory server, SunForum

tries to start a call with them.
Using SunForum 11



Using the SunForum Software

Refer to the SunForum conference manager as you read the procedures in this

section.

This section contains the following topics:

■ Making a Call

■ Sharing Applications

Making a Call

▼ To Make a Quick Connection

1. Choose View ➤ Address Book, or click the Address Book button.

2. Double-click on the address book entry that you want to connect to.

You can also simply click the Directory or History view buttons and double-click the

entry you want to connect to.

▼ To Connect Manually

1. Choose Call ➤ Place Call, or click the Call button.

The Place Call window is displayed. The Place Call window enables you to join a

conference.

2. Type the address with which you want to conference.

In the Place Call window, you can add the address you are calling to your Address

Book. You can also specify a named meeting to join (for example, if you are calling a

conference server).

3. Click OK.

The view will shift to Call Status if the connection is made, or a prompt will inform

you why the attempt was unsuccessful.

▼ To End a Connection

● Choose Call ➤ Hang Up, or click the Hang Up button.

This ends your participation in a conference.
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Note – When you hang up, you can also disconnect others from the conference. This

includes all the participants you invited into the conference, or anyone who called

you. If you initiated the conference, the whole conference will be terminated. You

will get a warning message if you are about to disconnect others by hanging up.

Note – You can also place calls through a gateway, see Chapter 4 “Configuring

Gateway Software.”

Sharing Applications

▼ To Share Applications

When you are using the SunForum software, the applications on your entire desktop

screen can be shared with other conference participants. This results in the

following:

■ If a controlling user within a SunForum conference moves an application window

on their desktop, it is actually moved on the host desktop. Other applications on

the host desktop may obscure the window being shared. If a portion of the shared

application window is obscured on the host desktop, that same portion is also

obscured on the controlling user’s desktop.

■ Sun and PC desktops in a SunForum conference may have different desktop

screen sizes. When controlling users move shared windows around on their

desktop, the windows may move outside the viewing area of a user in the

conference with a smaller desktop screen. A participant with a smaller desktop

screen can move (scroll) the active (view) region of the screen by moving the

mouse pointer to that area of the desktop where the entire application can be

viewed. (To set the scrolling feature, choose Tools ➤ Options from the SunForum

conference manager.)

1. While in a conference call, choose Tools ➤ Share, or click the Share button.

Or, choose Tools ➤ Share Application to select the application you want to share.

2. Place your mouse pointer (now a hand symbol) over the desktop application
window you want to share.

3. Click anywhere in that application window.

All conference participants can now see that application on their system as if it were

running locally. SunForum can share almost any application, including terminal

windows, word processors, and CAD design packages. Exceptions include

SunForum and applications using certain X extensions that are not supported.
Using SunForum 13



Note – The window is labeled with the name of the user who shared the

application. At this point, only that person can control it; others can only view the

output on their desktop.

▼ To Unshare Applications

1. Choose Tools ➤ Unshare, or double-click Unshare, to stop sharing the application.

2. Click on the application window that was being shared.

Now, only you can view and control that application.

▼ To Collaborate Applications

Once an application is being shared, the Collaborate button is activated and you can

open the application to conference participants for collaborative use.

1. Share an application (see To Share Applications).

2. Choose Tools ➤ Collaborate, or click Collaborate.

The shared application that was view-only by the conference participants is now

open for collaboration.

When you collaborate your shared application, other conference participants can

take control. For a conference participant to take control of the shared application,

they only need to click on that application on their desktop.

Note – When another conference participant clicks the shared application window

and is then in control of it, that person effectively take over your mouse and

keyboard. Only one user can be in control at a time. Any other user, including the

host, can gain control by just clicking the mouse.

● To stop collaborating, click Collaborate again.

The shared application is returned to view-only for the conference participants.

▼ To Transfer Files

1. Choose Tools ➤ Send File, or click Send File.

The Select a File to Send window is displayed.

2. Go to the directory and select the file you want to send.
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3. Click OK.

The file is sent to all the participants in the conference.

Files sent to you by other conference participants are received automatically. While

the file is being received, another window shows the progress of the transfer. When

the transfer is complete, the file is saved. The default directory for saving files is

/tmp . To change the default directory where files are saved, choose Options ➤ Tools

Settings.

▼ To Chat

1. Choose Tools ➤ Chat, or click the Chat button to start the chat application.

This also automatically starts the chat application on other user systems in the

conference.

2. Select the recipient of your message.

■ To send to all participants, choose Send to ➤ Everyone in conference.

■ To send to a single participant, choose Send to ➤ user name.

The names of those conference participants who are running chat are listed in the

Send to menu.

3. Type your message in the message field and press Return.

The message is displayed in your chat window and on the other participants’ chat

windows.

You can list the date, time, and name with the message. To do this, click View on the

Chat menu bar and select or deselect your choice.

You can save chat sessions to a file as a record of the conference. You are prompted

to do so when you exit the Chat window.

Note – Though other conferencing products may have T.120 text chatting capability,

they may not necessarily work with SunForum chat. Check the chatting status in the

SunForum conference manager to see who is running chat.

▼ To Transfer Data Using the Shared Clipboard

1. Ensure that Shared Clipboard is enabled on both systems.

2. Choose Tools ➤ Shared Clipboard.

The Shared Clipboard menu item should be active (checked).

Note – To automatically enable Shared Clipboard, choose Tools ➤ Options.
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3. Select text from an application (for example, a Command Tool) on one system.

4. Choose Edit ➤ Copy.

5. In an application (for example, a text editor) on another system, choose
Edit ➤ Paste.

Using the SunForum Audio and Video

The H.323 audio and video communications protocol is the standard for audio/

video conferencing. SunForum conforms to the H.323 standard.

This section contains the following topics:

■ Types of Audio/Video Conferences

■ Configuring Audio and Video Capabilities

■ To Set Audio/Video Options

■ To Set Audio/Video Device Options

■ Controlling Audio Within the Conference

■ Controlling Your Video Image Over a Conference

■ Controlling Video Image Within a Multipoint Conference

■ Controlling Video Within a Point-To-Point Conference

Types of Audio/Video Conferences

Conferencing products may provide one of three different levels of audio/video

support.

■ Multipoint - You can see and hear many people in the call at the same time. Each

person’s video image appears in a separate window, and the audio information

from each person is mixed together so that you hear a single audio channel

including everyone’s voice.

■ Point-to-point - You can see and hear one other person in the call at a time, and can

switch from one to another.

■ No audio/video - You cannot see or hear other people in the conference. Users of

conferencing products that do not support audio/video often set up a telephone-

based conference call in parallel with the SunForum conference.

SunForum provides multipoint support, but can also operate in point-to-point mode

or without audio/video to support conferences with other products:
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■ If everyone in the conference is using a product that supports multipoint audio/

video, you can use either multipoint or point-to-point. (You may prefer to use

point-to-point if people are familiar with products that operate only in this

mode.)

■ If some people are using a product that supports only point-to-point audio/

video, you should use point-to-point. SunForum can be configured to force a

conference to use point-to-point thus insuring that the products that only support

point-to-point can establish audio/video links.

■ Anyone who is using a product that does not support audio/video can still

participate in the conference, but will not be able to see or hear other people. You

can still use audio/video to communicate with anyone in the conference who has

support for it.

When you start a call to another person, SunForum initially creates a point-to-point

link for audio/video support regardless of the capabilities of the other product.

Should a third person join the conference, their capabilities will determine if the

conference becomes a multipoint conference or remains a point-to-point conference.

Once a conference has become a multipoint conference, products that do not support

multipoint will not be able to establish an audio/video link in the conference.

If you want to start a conference explicitly in point-to-point mode, you can specify

this in the Audio/Video Settings dialog box. See To Set Audio/Video Device

Options for more information.

In the current call window, the audio/video icons indicate an audio/video link to a

participant in the conference.

FIGURE 2-3 Conference Manager Audio and Video Icons
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Configuring Audio and Video Capabilities

▼ To Set Audio/Video Options

● Choose Options ➤ Audio/Video Settings.

Or, choose View ➤ Audio/Video Settings in your video display window or the video

display windows of others if you are in a conference.

TABLE 2-5 Audio and Video Options

Menu Item Description

Use point-to-point

Audio/Video

connections

This option allows you to only use point-to-point connections for

your audio/video conferences. This guarantees that users who only

support point-to-point will be able to utilize Audio and Video as

part of the conference.

Send image size Specify the size of your video image as it appears to other people.

This also determines the size of the My Video window on your

screen. The range of window sizes that you can use depends on the

capabilities of the conferencing products being used by other

people. If you are already in a conference, one or more of these

options may be grayed if other people are using conferencing

products that cannot support them. You may find that the window

size changes when you start a call, or when another person joins or

leaves the conference. This is because another person may not be

able to use the size that you originally selected; SunForum

cooperates with the other conferencing products to select the best

compromise between the requirements of everyone currently in the

conference.

Default video

magnification

This option specifies the default magnification (100% - 400%) used

to display video on your system.

I prefer to receive... This option allows you to tune the picture quality of the video

images of other people as they appear on your screen.

- Move the slider towards Faster Video to view the video with

more updates per second. This gives a smoother display, but

reduces the resolution of the image.

- Move the slider towards Better Quality to view the video with

higher resolution. This gives a better-quality video image, but may

mean that the video appears less smooth.
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▼ To Set Audio/Video Device Options

● Choose Options ➤ Audio/Video Device Settings.

Using the Sun 1394 Camera Snap Feature

You can snap a video image directly from the camera with the Sun 1394 Camera.

This allows you to capture an image at any location within a 3.0 meter range (1394

cable length) away from your workstation. This feature is activated through

SunForum (see “Capturing and Copying Video Images” on page 29).

Connection speed Select the option that best describes the network over which you are

using SunForum 3.2.

Echo suppression If selected, SunForum 3.2 disables your microphone when it is

playing back audio. Also called half-duplex, this is useful when

using a speaker and not a headset.

Auto Gain Control If selected, SunForum 3.2 will automatically adjust the sensitivity of

your microphone based on the input level.

TABLE 2-6 Audio and Video Device Options

Menu Item Description

Audio Device Allows you to choose the audio device to use for conferencing and

the attributes associated with that device. First you select the audio

device you want to use from the menu and then you push the

“Settings” button to configure the device specific attributes. Each

device is a unique attribute that can be configured.

Video Device Allows you to choose the video device to use for conferencing and

the attributes associated with that device. One choice is “None” for

systems without video capture capabilities or for those who are

capable but choose to disable it. First you select the video device

you want to use from the menu and then you push the “Settings”

button to configure the device specific attributes. Each device is a

unique attribute that can be configured.

TABLE 2-5 Audio and Video Options (Continued)

Menu Item Description
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Controlling Audio Within the Conference

You can adjust your own audio and adjust the audio you receive from the conference

participants.

To Adjust Your Audio Over a Conference

The checkbox to the left of the Conference Manager Microphone icon indicates

whether your audio is being played to other people in the call.

■ To start or stop playing your audio to other people in the call, click on the

checkbox to the left of the icon.

■ To control the output level of your audio, move the slider to the right to make

your audio louder, or to the left to make it quieter. This is important in a

multipoint conference, where this slider determines the volume of your audio

relative to other people’s audio.

■ If you are using point-to-point audio/video, only the person that you are

currently switched to will be able to hear you. To switch to a different person

in the call, see Controlling Video Within a Point-To-Point Conference.

To Adjust Conference Audio on Your Computer

The checkbox to the left of the Speaker icon indicates whether other participant’s

audio is being played on your computer.

■ To start or stop listening to other people in the call, click on the checkbox to the

left of the icon.

■ To control the volume, move the slider to the right to increase the volume, or to

the left to decrease it.

■ If you are using point-to-point audio/video, you will hear only the person that

you are currently switched to. To switch to a different person in the call, see

Controlling Video Within a Point-To-Point Conference.

Controlling Your Video Image Over a Conference

Before starting a call using video, you can check the video image of yourself that

will appear on other participant’s screens (for example to make sure that the camera

on your system is aligned correctly). The video image appears on your screen in a

window with the title My Video. You can show or hide the My Video window at any

time.
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▼ To Control Your Video Image Before a Conference

● Choose Tools ➤ Video ➤ Display My Video.

You can also hide the window by closing it. Prior to entering a call you will see the

message Not Sending beneath the My Video window.

Note – SunForum 3.2 software enables you to zoom your video display window.

To Control Your Video Image During a

Conference

Once in a call, a button is displayed in addition to the status message at the bottom

of the My Video window. The status message reflects the current state of video

transmission. The button is used to change that state as follows:

■ If the video status is “Sending”, the Pause button is shown. Click on this button to

pause the video display. When you pause the display, a “freeze frame” image

appears in the window and the status message becomes “Paused.”

■ If video status is “Paused”, the Play button is shown. Click on this button to

activate the video display. When you activate the display, video transmission is

restarted and the status message becomes “Sending”.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play

option that appears in the View menu of this window. These options only appear

when in a call.

You can control whether your video image is automatically sent to other people as

soon as you start a call; see To Set Audio/Video Device Options for more

information.

Controlling Video Image Within a Multipoint

Conference

If you are using multipoint audio/video, a video image of each person in the call is

displayed automatically when he or she starts sending video.

■ Each participant’s image is displayed in a separate window, with the participant’s

name as the window title. As other people join or leave the call, new windows

appear or existing windows disappear.

■ You can choose which of these windows are displayed on your screen.
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▼ To Control Video Image Within a Multipoint Conference

● Choose Tools ➤ Video ➤ Display Others.

Click on an entry for the window you want to display or hide. Alternatively, you can

hide a displayed window by closing the window using the system menu.

At the bottom of each of these windows, a button indicates whether the video is

being displayed, as follows:

■ If the video status is “Receiving”, the Pause button is shown. Click on this button

to pause the video display. When you pause the display, a “freeze frame” image

appears in the window and the status message becomes “Paused”.

■ If video status is “Paused”, the Play button is shown. Click on this button to

activate the video display. When you activate the display, video transmission is

restarted and the status message becomes “Receiving”.

You can control whether you automatically display video images of other people as

soon as they start sending video; see To Set Audio/Video Options for more

information. If you do not display these images, the window for a remote user on

your screen remains blank until you use the Play button to start the video display.

Instead of the Pause/Play buttons in the window, you can use the Pause or Play

option that appears in the View menu of this window.

Note – The window size used for other people’s video is determined by the

sender’s conferencing product and capabilities.

Controlling Video Within a Point-To-Point

Conference

In point-to-point audio/video, you can see and hear only one other person in the

conference at a time. You can switch between different people in the conference; if

you switch to a different person, the person you were previously seeing and hearing

remains in the conference but is not switched to anyone.

Note – The switch attempt will fail if you try to switch to a person who is already

switched to someone else.
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▼ To Switch to Another Person

● Choose from the Tools ➤ Switch Audio and Video.

This displays a list of people that you can switch to, including the person you are

currently switched to (with a selection marker next to that person’s name). The list

does not include people who do not have audio/video support.

■ To switch to a different person, click on that person’s name in the list.

■ To “switch out” so that you remain in the conference but are no longer switched

to anyone, click on the name of the person you are currently switched to (the

name with the selection marker next to it).

The Switch Audio and Video menu item only appears if you are in a conference with

more than one audio/video capable person and are using point-to-point

connections.

Displaying Remote Video in a Point-To-Point

Conference

If you are using point-to-point audio/video, the Remote Video window displays a

video image of the person you are currently switched to (if any).

■ To switch to a different person in the call, see Controlling Video Within a Point-

To-Point Conference.

■ You can choose whether to display this window on your screen by displaying

Remote Video.

▼ To Display Remote Video

● Choose Tools ➤ Video ➤ Display Others’ Video.

This displays or stops displaying the window. Alternatively, you can close the

window by clicking on the Close button for the window.
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Using the SunForum Whiteboard

The SunForum Whiteboard enables all conference participants to exchange ideas and

graphics. You do not need to be in a conference, however, to use the whiteboard.

There are two types of whiteboards available through SunForum:

■ T.126 mode, which allows you to interoperate with any computer system or

appliance using the T.126 protocol, regardless of platform software

■ SunForum 1.0 mode, which allows you to interoperate with certain collaboration

software running on PCs.

This section contains the following topics:

■ To Select a Whiteboard Mode

■ To Draw Graphical Objects

■ To Use Text Objects

■ To Move and Delete Objects

■ To Highlight Text and Images

■ To Capture (Snap) Video Images

■ To Add Screen Captures to the Whiteboard

■ To Import Graphics

■ To Export Graphics

■ To Use the Remote Pointer

■ To Use Whiteboard Stamps

■ To Copy to the Clipboard

■ To Navigate and Organize Pages

■ To Add a New Page

■ To Zoom the Whiteboard

■ To Lock the Whiteboard

■ To Save the Whiteboard Contents to a File

■ To Print the Whiteboard Contents

▼ To Select a Whiteboard Mode

1. Choose Options ➤ Tool Settings.

2. Choose the desired whiteboard mode: T.126 or SunForum 1.0 mode.
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3. Click OK.

Note – Once you select a whiteboard in the Options window, this whiteboard will

open each time you select Whiteboard from either the Tools menu or from the

Whiteboard button on the SunForum conference manager. See To Start the

Whiteboard.

▼ To Start the Whiteboard

● Choose Tools ➤ Whiteboard, or click the Whiteboard button, from the SunForum
conference manager.

The whiteboard mode you selected in the Options window is displayed. This

example shows the SunForum T.126 mode whiteboard.

FIGURE 2-4 SunForum 3.2 Whiteboard
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Whiteboard Menus

Whiteboard Tool Panel

Familiarize yourself with the whiteboard by experimenting with the drawing

features in the drawing tool panel to the left of the whiteboard. You do not need to

be in a conference to do this.

FIGURE 2-5 Whiteboard Tool Panel

TABLE 2-7 Whiteboard Menu Bar Descriptions

Menu Description

File For file handling functions such as New, Open, Save, Import,

Export, and Print.

Edit To edit functions such as copy, paste, clearing, deleting, inserting

pages, and so on.

Tools To select drawing functions. You can also click the icon on the draw

tool panel on the left side of the whiteboard.

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window

Lock

SunForum 1.0 mode

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

Select area

Text tool

Highlighter

Zoom

Filled rectangle

Filled ellipse

Remote pointer

Selector

Freehand pen

Straight line

Rectangle

Ellipse

Select window Select area

Snap My Video Enable camera

T.126 mode

Snap My Video Enable camera
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▼ To Draw Graphical Objects

1. Click the tool type in the whiteboard tool panel.

For example, click freehand pen or choose Tools ➤ Pen from the menu bar.

2. Choose your pen color and line thickness.

a. Click the Whiteboard Options button located on the bottom of the whiteboard.

FIGURE 2-6 Whiteboard Options Button

The Whiteboard Options panel is displayed.

FIGURE 2-7 Whiteboard Options Panel

b. Choose your pen color and pen width, then click OK.
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3. Click and drag your mouse button to draw the object.

As you release the mouse button, the object is seen by all other conference

participants.

To Use Text Objects

Creating Text Objects

1. Click the Text tool button, or choose Tools ➤ Text.

2. Place your mouse pointer in the whiteboard where you want to enter text.

3. Click at that location.

A text field appears in the whiteboard.

4. Enter the text and click OK.

Editing Text Objects

1. Click the Text tool button, or choose Tool ➤ Text.

2. Click the text in your whiteboard that you want to edit.

A text field appears in the whiteboard.

3. Edit the text and click OK.

Setting the Font and Style of Text Objects

You can set font options in two ways:

■ By changing settings in the Whiteboard Options tool before creating a new text

object

■ By selecting a text object, then changing the settings in the Whiteboard Options

tool.

■ By selecting a text object, then changing the settings when the text field is visible.

1. Click the Whiteboard Option button.

The Whiteboard Options window is displayed.
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2. Click the Text Font, Text Size, and Text Style menus and choose the font setting.

Note – Only a small number of fonts are available to ensure that text objects are able

to display on all user systems in the conference.

3. Click OK on the Whiteboard Options window.

▼ To Move and Delete Objects

1. Click the Selector tool button, or choose Tools ➤ Selector.

2. Click the graphic or text that you want to move or delete.

A border is highlighted on the selected object.

a. To move the graphic or text, drag it with the mouse pointer to its new position.

b. To delete the graphic or text, press Delete on your keyboard, or choose
Edit ➤ Delete.

Note – If you delete an object by mistake, you can undelete and retrieve the last

deletion by choosing Edit ➤ Undelete.

▼ To Highlight Text and Images

1. Click the Highlight button, or choose Tools ➤ Highlighter.

2. Draw on the whiteboard area you want to highlight.

Capturing and Copying Video Images

You may snap a camera video image from either the whiteboard tools panel, or from

the Sun 1394 Camera snap button, and copy it as an image to the whiteboard.

▼ To Capture an Image from the Whiteboard Tools Panel

1. Select the camera video image you wish to capture.

2. Click the Snap My Video from the Whiteboard tools panel (see FIGURE 2-5), or
choose Tools ➤ Snap My Video from the Tools menu.

The image appears and is copied in the top left corner of the Whiteboard window.
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▼ To Capture an Image Using the Sun 1394 Camera

1. Click the Enable Camera button on the whiteboard tools panel (see FIGURE 2-5).

This enables the Sun 1394 Camera snap button so that each time you press the

camera snap button, the image is captured on the Whiteboard.

2. Focus on the image to be captured and press the Sun 1394 Camera snap button.

If you do not use the camera snap button for a period of 60 seconds, then the snap

button becomes disabled again.

Note – If you want to disable the snap button on the camera before the timeout

period expires, simply press the Escape key.

To Add Screen Captures to the Whiteboard

You can capture the contents of a window, or an area of the desktop, to add to your

whiteboard for conferencing.

Selecting and Capturing a Window

1. Click the Select window button, or choose Tools ➤ Select Window.

The whiteboard becomes an icon and the mouse pointer becomes a hand symbol.

2. Place the mouse pointer on the window you want to add to your whiteboard.

3. Click the window.

The window is captured and placed in your whiteboard.

Selecting and Capturing an Area of the Screen

1. Click the Select window button, or choose Tools ➤ Select Area.

The whiteboard becomes an icon and the mouse pointer becomes a pair of

crosshairs.

2. Drag the mouse pointer over the area of your desktop screen that you want to
capture.

The image area is captured and placed in your whiteboard as you release the mouse

button.
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Note – Once the image is captured in the whiteboard, you can use the Selector tool

to select the image and move or delete it across your whiteboard. See To Move and

Delete Objects.

▼ To Import Graphics

1. Choose File ➤ Import.

The Select a file to import window is displayed.

2. Specify the file you want to import and click OK.

The image is added to the current page.

Note – You need the shareware filter ghostscript to import PostScript files into

the whiteboard. The location of ghostscript must be separately specified in

/etc/opt/SUNWdat/config/system-config as Whiteboard.GSPath.

▼ To Export Graphics

1. Choose File ➤ Export.

The Export file window is displayed.

2. Specify the file you want to export.

3. Choose an image format from the Save file as type menu.

4. Click OK.

The contents of the current page is written to the file in the selected format.

▼ To Use the Remote Pointer

The remote pointer is a pointing hand that everyone in the conference can see. When

you have the Select tool enabled, you can click on the pointer and drag it around, so

that you can point out areas of interest on the page.

1. Click the Remote Pointer button, or choose Tools ➤ Remote Pointer.

A hand symbol pointer is displayed on your whiteboard.

2. Click and drag the remote pointer to move to selected areas of interest.
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▼ To Use Whiteboard Stamps

The Whiteboard Stamps window offers a number of images you can “stamp” on the

whiteboard. These are user configurable. The SunForum software enables you to use

bitmap files (such as GIF) in user-defined locations.

Note – The location is /etc/opt/SUNWdat/config/dcgx , listed as

Whiteboard.StampFilename.1 through Whiteboard.StampFilename.12 . You

may have more than 12 stamps, however.

1. Click the rubber stamp button.

FIGURE 2-8 Rubber Stamps Button

The Whiteboard Stamps window is displayed.

FIGURE 2-9 Whiteboard Stamps Window
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2. Click on a stamp image and click OK.

When you place the pointer in the whiteboard, the pointer is a stamp.

3. Place the stamp pointer in the whiteboard where you want the image to appear
and click.

The stamp image is displayed.

To Copy to the Clipboard

You can cut and paste to and from a clipboard in two ways:

■ Using the quick method to copy text

■ Using the Edit commands to cut and paste text and graphics

Using the Quick Method to Copy Text

1. Select text in the whiteboard (or another text source window) or from another
application.

2. Place the mouse pointer in the whiteboard and click the middle mouse button to
paste the text selection.

Using the Edit Commands

1. Select the text or object you want to copy.

2. Choose Edit ➤ Cut or Edit ➤ Copy.

3. Go to a new whiteboard page and choose Edit ➤ Paste.

▼ To Navigate and Organize Pages

● To navigate pages, use the navigation arrows at the bottom of the whiteboard to
change pages; or, use the Edit menu to clear, delete, insert, and to go to specific
pages.

● To organize pages, choose Edit ➤ Bring to Front or Edit ➤ Send to Back to move
the current page accordingly.
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▼ To Add a New Page

● Click the new page button or choose Edit ➤ Insert Page, located in the bottom
right corner of the whiteboard.

A new page is added after the current page.

FIGURE 2-10 New Page Button

Note – Using the menu to insert a page enables you to place the new page before or

after the current page.

▼ To Zoom the Whiteboard

● Click the Zoom button, or choose Tools ➤ Zoom.

This changes the magnification of the whiteboard contents you are viewing.

▼ To Lock the Whiteboard

You can lock the whiteboard so that no one else in the conference can make any

changes to the contents.

1. Click the Lock button, or choose Tools ➤ Lock.

After a short delay, either you will have successfully locked the whiteboard

(indicated by the lock “down” position), or you will be notified that it could not be

locked. You may not be able to lock it because another user in the conference has

already locked the whiteboard or is in the middle of an operation that cannot be

interrupted.

2. Click the lock button a second time to release the lock.

Note – Locking feature cannot be used in a T.120 whiteboard.
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▼ To Save the Whiteboard Contents to a File

● Choose File ➤ Open.

or

● Choose File ➤ Save (or File ➤ Save As).

▼ To Print the Whiteboard Contents

● Click the Print button, or choose File ➤ Print.

FIGURE 2-11 Print Button

In the print window, specify the printer or file name to print to, and which pages

you want to print.

Note – The printer name must be a valid printer device. The SunForum software

allows you to also specify a networked printer name.
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CHAPTER 3

SunForum Phone

This chapter contains the following topics:

■ “Starting the SunForum Phone” on page 37

■ “SunForum Phone Menus” on page 39

■ “Using the SunForum Phone” on page 41

■ “My Video” on page 43

■ “Audio and Video Device Settings” on page 44

■ “Media Configuration Wizard” on page 45

■ “Preferences” on page 46

Starting the SunForum Phone

● After installing SunForum 3.2 software packages, type the following at your
system prompt:

Note – If the SunForum directory is not set in your path, type the correct path name

(for example, /opt/SUNWdat/bin/phone ).

The SunForum Phone is displayed (FIGURE 3-1).

% phone
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FIGURE 3-1 SunForum Phone

Note – Once the SunForum Phone displays, you can toggle the SunForum

conference manager from the Phone user interface Controls menu. You cannot start

the Phone from the SunForum conference manager, however, if SunForum is started

first.

Note – The SunForum Phone interface is used for audio and video calls. For data

collaboration or advanced settings, you must toggle to the SunForum conference

manager interface (see Chapter 2 “Using SunForum”).

Call edit field

Phone keypad

Place Call button

Hang Up button

Clear button

Volume indicator

Phone mic

Volume button

Volume control buttons

Name field

My Video button
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SunForum Phone Menus

There are four menus on the SunForum Phone menu bar: Call, Controls, Address

Book, and Help. The following tables describe each of the Phone menu options.

Call Menu

Note – The Place Call menu item and Call button on the Phone interface are

disabled until you enter an address in the Call Edit field (FIGURE 3-1).

TABLE 3-1 Call Menu

Menu Description

Place Call To place a call to an indicated address. You can also click the

Phone Call button.

Hang Up To end your call. (Same as clicking the Hang Up button.)

Change My Information To make changes to your SunForum profile information.

Directory To view the directory server. It lists those with whom you can

conference.

List of phone numbers A history list of the last dialed numbers (lists a maximum of

10 phone numbers)

Exit To exit the SunForum Phone software.
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Controls Menu

Address Book Menu

The SunForum Phone Address Book menu lists the user’s addressbook and

addresses not frequently used. The history portion of the Call menu contains a list of

the 10 most previously used addresses, however.

There are three types of addresses a user can create in the Add Address and New

Address windows:

■ Telephone: a telephone number to be used with a gateway

■ Network (TCP/IP): a call alias used with a Sun Gatekeeper

■ Directory: an LDAP directory to use with the address

TABLE 3-2 Controls Menu

Menu Item Description

Volume To increase, decrease, or mute volume.

Microphone To toggle the microphone on or off.

Toggle SunForum To open and close the SunForum conference manager.

Audio/Video Device

Settings

To select audio and video devices and to configure the settings of

each.

Media Config

Wizard

This provides help in configuring your audio and video device

settings.

Preferences To set preference conditions for Incoming Calls, Telephone Key, and

Cursor.

TABLE 3-3 Address Book Menu

Menu Item Description

Add Address To add an address to the Address Book. This is only available when

a conference participant is selected in the Phone roster, during a

conference. This fills the address information for the user.

New Address To add a new address. This is always available.

Edit Address Book This displays a list of addresses in your address book and enables

addresses to be created, edited, or deleted.

List of addresses A list of addresses that are frequently conferenced.
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Help Menu

You can access help information from the Help menu located on the SunForum

Phone menu bar

● Choose Help ➤ Phone Help for online SunForum Phone information.

or

● Choose Help ➤ Popup Help.

Popup Help toggles Help messages that are displayed underneath the cursor when

the cursor is positioned on many of the Phone GUI controls.

Using the SunForum Phone

Once your SunForum Phone is displayed and you have configured the audio and

video device settings and phone preferences to your needs (TABLE 3-1 and TABLE 3-2),

you are ready to place a call.

Placing a Call

Besides using the Phone menu bar to place calls, you can use the Phone user

interface.

▼ To Place a Call Through the Phone Interface

● Click the phone number you wish to call on the phone interface keypad.

The number is displayed in the field just above the keypad. Then click the Place Call

icon to place the call (FIGURE 3-2).

or

● Type the phone number, or alias name, from your computer keyboard.

The number is displayed in the field just above the keypad. Press Return on your

keyboard (or click the Place Call icon) to place the call.
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Once you have placed the call, an Outgoing Call window displays as it dials the

number. You can also cancel the call from the Outgoing Call window.

FIGURE 3-2 Placing a Call

▼ To Clear a Number That You Have Entered

● Clear the number from your keyboard by selecting the entire Call edit field and
pressing Delete.

or

● Click the Clear button until the number is erased.

▼ To Turn On the Phone Microphone

● Click the Phone mic button.

Note – A computer phone microphone/headset is recommended for each

participant in the conference.

Call edit field

Phone keypad

Place Call button

Hang Up button

Clear button

Volume indicator

Phone mic

Volume button

Volume control buttons

Name field

My Video button
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My Video

You can view your video that is being broadcast over a conference and configure

your audio and video settings. To do this:

1. Double click the My Video button (FIGURE 3-2) next to your name in the Name
field. See FIGURE 3-2.

The My Video window is displayed.

2. From the My Video menu bar, choose View ➤ Audio/Video Settings.

The Audio/Video Settings window is displayed. TABLE 3-4 describes the setting

options.

TABLE 3-4 Audio and Video Settings

Menu Item Description

Use point-to-point

Audio/Video

connections

This option allows you to only use point-to-point connections for

your audio/video conferences. This guarantees that only users who

support point-to-point will be able to utilize Audio and Video as

part of the conference.

Send image size Specify the size of your video image as it appears to other people.

This also determines the size of the My Video window on your

screen. The range of window sizes that you can use depends on the

capabilities of the conferencing products being used by other

people. If you are already in a conference, one or more of these

options might be disabled if other people are using conferencing

products that cannot support them. You might find that the window

size changes when you start a call, or when another person joins or

leaves the conference. This is because another person might not be

able to use the size that you originally selected; SunForum

cooperates with the other conferencing products to select the best

compromise between the requirements of everyone currently in the

conference.

Default video

magnification

This option specifies the default magnification (100% - 400%) used

to display video on your system.

I prefer to receive... This option allows you to tune the picture quality of the video

images of other people as they appear on your screen.

- Move the slider towards Faster Video to view the video with

more updates per second. This gives a smoother display, but

reduces the resolution of the image.

- Move the slider towards Better Quality to view the video with

higher resolution. This gives a better quality video image, but might

mean that the video appears less smooth.
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Audio and Video Device Settings

▼ To Set Audio/Video Device Options

● Choose Controls ➤ Audio/Video Device Settings from the Phone menu bar.

Connection speed Select the option that best describes the network over which you are

using SunForum 3.2.

Echo suppression If selected, SunForum 3.2 disables your microphone when it is

playing back audio (half-duplex).

Auto Gain Control If selected, SunForum 3.2 automatically and continuously adjusts

the sensitivity of your microphone based on the input level.

TABLE 3-5 Audio and Video Device Options

Menu Item Description

Audio Device Enables you to choose the audio device to use for conferencing and

the attributes associated with that device. First select the audio

device you want to use from the menu and then click the “Settings”

button to configure the device specific attributes. Each device is a

unique attribute that can be configured.

Video Device Enables you to choose the video device to use for conferencing and

the attributes associated with that device. One choice is “None” for

systems without video capture capabilities or for those who are

capable but choose to disable it. First select the video device you

want to use from the menu and then click the “Settings” button to

configure the device-specific attributes. Each device is a unique

attribute that can be configured.

TABLE 3-4 Audio and Video Settings (Continued)

Menu Item Description
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Media Configuration Wizard

The SunForum Phone Configuration Wizard helps you configure your audio and

video settings. TABLE 3-6 describes the Configuration Wizard device settings and

tests.

1. Choose Controls ➤ Media Configuration Wizard from the Phone menu bar.

Be sure to close all other applications that use audio and video.

2. Click Next at each window to progress through the configuration pages (TABLE 3-6).

3. Click Finish on the last page when done.

Note – While in a call, the Media Configuration Wizard is unavailable.

TABLE 3-6 Media Configuration Wizard

Menu Item Description

Media Device Setting Enables you to choose which audio and video device SunForum

will use for conferencing and the attributes associated with that

device. First select the audio and video device you want to use from

the Audio and Video Device menu. Click the “Settings” button to

configure the device-specific attributes. Each device is a unique

attribute that can be configured.

Audio Output Enables you to check that your speakers and headphones are

working properly. Click the Test button to play test audio and

adjust the volume slider accordingly.

Microphone Level Enables you to confirm that your microphone is working correctly

and automatically adjusts it to an acceptable level.
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Preferences

The SunForum Phone Preferences window (FIGURE 3-3) enables you to configure

incoming calls, telephone key, and cursor action. TABLE 3-7 describes the Preferences

configuration window.

FIGURE 3-3 SunForum Phone Preferences Window

● Choose Controls ➤ Preferences from the Phone menu bar.

TABLE 3-7 SunForum Phone Preferences

Menu Item Description

Incoming Calls To enable type of ring for incoming calls, to set continuous or

number of rings, to set interval of rings in seconds, and to set the

ring through your speaker. Ring Through Speaker forces the ringer

to play through the external speaker on incoming calls. This enables

you to still hear the ringer if a headset is being used.

Telephone Key Enables you to assign a key which you can use to answer incoming

calls. You can select to use either the Control, Alt, Meta keys as your

function keys (for example, Alt-F5).

Cursor Provides the option in a call address field of blinking, steady, or no

cursor action.
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CHAPTER 4

Configuring Gateway Software

This chapter describes how to configure gateway software in order to place calls

over the network using the SunForum Phone.

Overview

The gateway software enables you to connect to a designated server that provides

the phone line connections required to place calls over a network when using the

SunForum Phone (see Chapter 3 “SunForum Phone”). Once you have updated your

gateway configuration file, you can then call the gateway server phone lines that

connect your calls over the network.

Gateway Configuration File
To update your gateway configuration file:

1. Become superuser in a shell window.

2. Go to the SunForum configuration directory:

3. Open the SunForum system configuration file:

# cd /opt/SUNWdat/config

# vi system-config
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4. Locate the gateway settings portion of the configuration file and type the required
information.

In this example, the server name to be designated as the gateway server is Server 1

and 011# is the gateway prefix that may be required to place the call to a gateway

server.

5. Save the file, exit superuser, and start SunForum Phone (see Chapter 3 “SunForum
Phone”).

The SunForum Phone Controls menu now lists Gateway Mode.

6. Toggle Gateway Mode from the Controls menu.

The SunForum Phone display changes to the gateway mode (FIGURE 4-1).

FIGURE 4-1 SunForum Phone GUI in Gateway PBX Mode

!
! Gateway settings
!
H323.CallViaGateway:  TRUE
H323.GatewayName:  server1
H323.GatewayPrefix:  011#
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Using SunForum Phone Gateway

FIGURE 4-2 shows an example of a networked system accessing a gateway server.

This example shows Sun Ultra workstations and Sun Ray systems connected to the

network. (For more information on SunForum and Sun Ray systems, see Chapter 5

“SunForum on a Sun Ray System.” Sun Ray systems require Sun Gatekeeper

software to place calls over a wide area network.)

FIGURE 4-2 Gateway Network Example of Systems Running SunForum 3.2

In this example, Sun workstations and Sun Ray systems are running SunForum 3.2

and SunForum Phone. Server 1 is a two-line gateway server and indicates the phone

lines required when making your calls to telephones. In order to place a call over the

network from your SunForum Phone, you must first dial and connect with the

designated gateway server. (Sun Ray systems, as shown, go through the Sun Ray

server and Sun Gatekeeper to dial into the network. See “Sun Gatekeeper Software”

on page 52.)

To dial your SunForum Phone into a network:

1. Start SunForum Phone.

2. Update the SunForum system configuration file.

See “Gateway Configuration File” on page 47.

LAN

Sun Ray

Ultra 10

Server 1

Ultra 10

Ultra 80

Sun Ray

Sun Ray server with
Sun Gatekeeper

Gateway
server

011# phone line
022# phone lineserver

PBX or
Telephone
company
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3. Choose Controls ➤ Gateway Mode.

The SunForum Phone display changes to the gateway mode.

FIGURE 4-3 Gateway Mode

4. In the Call edit field (FIGURE 4-3), enter the number you are calling.

5. Press Return, or click the Place Call button, to make the connection.

Note – This is similar to calling the gateway directly by using extension 011# at the

dial tone, dialing the phone number (in this example, 46953) using DTMF.

Call edit field
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CHAPTER 5

SunForum on a Sun Ray System

This chapter contains the following topics:

■ “Sun Ray Requirements” on page 51

■ “Sun Gatekeeper Software” on page 52

Sun Ray Requirements

Your Sun system server requires Sun Ray Server Software 1.2 to support

SunForum 3.2 software. Refer to your Sun Ray system documentation for installation

procedures of this software.

If Sun Ray 1.2 software patches for SunForum are available, install these patches

instead of the procedure in “Sun Ray Libraries” below.

Sun Ray Libraries

Note – The following instruction is only required when adding SunForum support

to Sun Ray Server 1.2 software.

Two Sun Ray libraries are required for installations using Sun Ray clients. The

libraries are: libutmedia.so and libutadmin.so .

To install these libraries:

● Copy both libraries from the CD-ROM supplementary directory into the Sun Ray
library directory /opt/SUNWut/lib/ .
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Sun Gatekeeper Software

Overview

SunForum 3.2 includes a H.323 gatekeeper that is required when using the

SunForum software with a Sun Ray system. After installing the SUNWkeeppackage,

the gatekeeper option is available. The SUNWkeeppackage is installed with the

SunForum 3.2 software (see SunForum 3.2 Software Installation Guide).

A gatekeeper is software that is used for call control and management of voice, video,

and data networks. After the gatekeeper is installed and started, H.323 users

(including SunForum users) register with it. IP addresses, along with H.323 aliases

(names and numbers) are used; all calls are then routed through this central location.

Though the gatekeeper software is required for using SunForum on Sun Ray

systems, it is also required in a Sun workstation conferencing environment when at

least one Sun Ray system wishes to join the workstation environment.

The Sun gatekeeper provided with SunForum 3.2 only provides address translation

and aliasing with port numbers. For this reason, the daemon is called a “registrar.”

(Sun gatekeeper does not support bandwidth management.)

A gatekeeper requires that each registrant have a unique alias or aliases. It is

suggested that each SunForum client use a telephone extension, email address, or

other unique name.

Starting Sun Gatekeeper

Note – Only one gatekeeper is allowed to run in any installation. You can install the

package in multiple locations, but only one server can start the gatekeeper daemon.

1. Decide which server will start the gatekeeper software.

2. Become superuser.
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3. Start Sun gatekeeper. Type:

Note – If the SunForum directory is not set in your path, type the correct path name

(for example, /opt/SUNWkeep/bin/registrar start ).

Editing the System Configuration File

The SunForum 3.2 clients are set up for “auto discovery” of the gatekeeper server as

a default. This auto discovery uses IP Multicast and may not penetrate routers going

across subnets. In this case, you need to specify the gatekeeper by name. To specify

the gatekeeper server, you need to edit the configuration file:

1. Become superuser.

2. Go to your system configuration file:

3. Change the configuration file default settings.

The following example uses “GK-server” as your selected server name.

Note – If a gatekeeper becomes unavailable (either by system or network failure),

incoming calls will fail. You should choose a gatekeeper server to be a reliable

machine on a reliable subnet.

4. To view who is registered in the gatekeeper, type:

# registrar start

# cd /opt/SUNWdat/config/
# vi system-config

Default setting: for auto discovery
H323.GKDiscovery: 1
H323.GKName: None

Change to: for manual gatekeeper specification
H323.GKDiscover: 2
H323.GKName: GK-server

% registrar -q
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CHAPTER 6

Technical Information

This chapter contains the following topics:

■ “SunForum Architecture” on page 55

■ “SunForum’s Conferencing Topology” on page 56

■ “SunForum’s Whiteboard and Compatibility Mode” on page 57

■ “Using the SunForum Software Through a Network Security Mechanism” on

page 58

■ “Using TrueType Fonts With SunForum Software” on page 59

■ “Calling Into a Multipoint Control Unit” on page 59

■ “Calling Into Password-Protected Conferences” on page 60

■ “Solving Color Problems” on page 60

■ “SunForum Software Support” on page 61

SunForum Architecture

The SunForum architecture is based on the International Telecommunications Union

(ITU) protocol standards H.323, which defines a set of multimedia communications

and conferencing over packet-based networks. The H.323 architecture includes the

foundations for audio (G.7xx standards), video (H.26x standards), and data

communications (T.120 family of standards). T.120 contains a series of

communication and application protocols and services that provide support for

real-time, multipoint data communications.

The G.7xx standards contain G.711, G.723 and G.729 for audio.

The H.26x standards contain the H.261 and H.263 standards for video compression.
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The T.120 architecture is a multilayered design, with defined protocols and service

definitions between layers. The upper-level layers require the lower-level layers of

the architecture to function.

The lower-level layers (T.122 through T.125) specify an application-independent

mechanism for providing multipoint data communication services to any application

that can use these facilities.

The upper-level layers define protocols for specific conferencing applications, such

as T.126 for viewing and annotating still images, T.127 for multipoint file transfer

and T.128 for application sharing.

Applications that use these standardized protocols can coexist in the same

conference with applications that use proprietary protocols. In fact, SunForum

software users can use a mix of standardized and nonstandardized protocols.

SunForum’s Conferencing Topology

In a SunForum conference, the topology and hierarchy of the connections is

conforming to the topologies for H.323 conferences and T.120 conferences. In a

multipoint H.323 conference, one endpoint is the Multipoint Controller, and every

other endpoint has a single direct connection to that Multipoint Controller. In a

point-to-point H.323 conference, there is no Multipoint Controller, and the two

endpoints simply have a direct connection. In the T.120 conference there is a more

complicated hierarchal topology, and this determines the behavior of the

connections. We will describe this in more detail.

In a T.120 conference, a hierarchy exists where the person starting the conference is

at the top and those joining the conference are underneath. Where a caller is in this

topology affects the conference connection of those who joined that particular caller

in the conference. This is illustrated in the following figure.

In this example,

■ If B hangs up, all those that B called are disconnected as well, leaving A and D in

the conference

■ If D hangs up, only D is disconnected, leaving A, B, and C in the conference

■ If A hangs up, the entire conference ends
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FIGURE 6-1 T.120 Conference Hierarchy

The way you create a conference is to establish one system, the conference host, for

conference participants to call in to. A star (as in a star networking protocol)

topology is created where anyone except the host can leave the conference

independently. (This host can actually be a dedicated conference server machine,

supporting several conferences simultaneously.)

SunForum’s Whiteboard and
Compatibility Mode

There are several types of whiteboards available through SunForum:

■ SunForum 1.0 mode, which allows you to interoperate with certain collaboration

software running on PCs. This is chosen through the menu system Options ➤ Tool

Settings... ➤ SunForum 1.0 mode.

■ "True T.126" mode, which allows you to interoperate with any computer system

or appliance using the T.126 protocol, regardless of platform software. This is

chosen by setting the T.126 mode and T.120 buttons in the Options ➤ Tool

Settings... panel.

Caller A

Caller B

Caller A Caller A

Caller DCaller C

Caller B Caller B

Caller C

A calls B B calls C (or C calls B) A calls D (or D calls A)

A begins conference
with B

C joins conference D joins conference
through Athrough B
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■ "NetMeeting 3.x style T.126" mode, which allows you to interoperate with the

NetMeeting 3.x whiteboard. This is chosen by setting the T.126 mode and

NetMeeting 3 buttons in the Options ➤ Tool Settings... panel.

Note that the choice of Compatibility mode in the Options ➤ Tool Settings... panel

affects other areas of SunForum as well. The most visible difference between the two

modes is in Application Sharing.

■ T.120 mode, is designed to comply to the T.120 standard, and in this mode,

SunForum should interoperate with other systems using the T.120 protocol stack.

This mode should be used for interoperating with NetMeeting 2.x.

■ NetMeeting 3 mode, which allows you to interoperate with certain collaboration

software running on PCs (NetMeeting 3.x in particular), and makes Application

Sharing resemble that of NetMeeting 3.01.

The selection of compatibility mode is made through the Options->Tool Settings...

menu item.

Using the SunForum Software Through a
Network Security Mechanism

If you are connected to the internet through a network security mechanism, or

firewall, (as is usual in most corporate/LAN environments), you can use SunForum

software to communicate with others located inside the firewall.

To enable full external communication, the firewall (that is, network security

mechanism) needs to be set up to allow communication through certain ports (that

is, the ports need to be “opened up”):

■ Ensure your workstation has its default gateway set to the internal address of the

network security mechanism computer.

■ Configure the network security mechanism to enable primary TCP connections

over the following IP ports:

■ 389 - for communication with Internet Locator Servers, if this is desired

■ 1503 - for T.120 data, i.e. application sharing, file transfer, whiteboard and chat

■ 1718 (UDP) - for locating H.323 gatekeepers (required only if automatic

gatekeeper discovery is used)

■ 1719 (UDP) - for communication with H.323 gatekeepers

■ 1720 (TCP) - for H.323 call setup
58 SunForum 3.2 Software User’s Guide • April 2001



■ Ensure that the firewall is configured to allow the use of dynamic IP ports (both

TCP ports for H.323 call control, and UDP ports for audio and video streams).

This may require the use of a special H.323-capable firewall product.

■ Configure the firewall to map internal IP addresses to external Internet addresses.

[This is not possible with all firewalls. If your firewall cannot do this, you will be

able to call out from inside the firewall, but you will not be able to receive

incoming calls from computers outside the firewall.]

If you are unsure whether you are connecting to the Internet via a network security

mechanism, consult your system administrator or Internet service provider.

Using TrueType Fonts With SunForum
Software

SunForum software is designed to take advantage of a TrueType font server if one is

installed on your system (or accessible to your system across a local area network).

Solaris 2.6 operating environment and subsequent compatible versions support

TrueType fonts.

With a TrueType font server installed, SunForum software will have more fonts in

common with PC systems, resulting in better quality output and improved

performance in sharing sessions involving both UNIX and PC systems.

Calling Into a Multipoint Control Unit

SunForum software supports Multipoint Control Unit (MCU) hosted conferences,

and has been tested with some of the MCUs available at the time of this release.

When calling an MCU, specify the address of the MCU as normal. If SunForum

software detects that the machine called is currently hosting more than one

conference, you will be prompted to specify which conference to join. Also, see

“Calling Into Password-Protected Conferences.”
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Calling Into Password-Protected
Conferences

You cannot create a password-protected conference with SunForum software.

When you call into a conference that has been designated as password-protected,

SunForum software will prompt you to specify the password.

Some T.120 implementations incorrectly list conferences as password-protected, even

when no password has been specified. In this case, just click OK without specifying

a password; the conference will be established as normal.

Optimizing Video Display

For better performance of video displays, increase the shared memory pool size to at

least 16 Mbytes. To do this,

1. Add the following line to the /etc/system file:

2. Reboot your system.

Solving Color Problems

If you experience problems with color operations (such as text highlighting) with

shared PC applications, try the following:

■ If your X Server is running with a Static or DirectColor default visual, switch it to

run with PseudoColor or GrayScale. See your X Server documentation for

information on how to do this.

■ Close any local color-intensive X applications (such as bitmap editors and web

browsers) to make more colors available for the SunForum software.

set shmsys:shminfo_shmmax=16777216
60 SunForum 3.2 Software User’s Guide • April 2001



SunForum Software Support

If you have any problems installing or using the SunForum software:

■ Refer to the written or online documentation included with the software.

■ Read the rest of the online help, especially the READMEpage, for a list of known

problems with this release.

■ If you are unable to find an answer, contact your Sun representative and have the

following information available:

■ Your system configuration (system hardware, operating system version,

graphics hardware)

■ A complete description of what you were doing when the problem occurred

■ Any core file generated (check the /opt/SUNWdat directory)

■ The contents of any error log files generated (look for hostname.trc1 and

hostname.trc2 , located in the $HOME/.sunforum/trc directory)
Technical Information 61



62 SunForum 3.2 Software User’s Guide • April 2001


	SunForum 3.2 Software User’s Guide
	Contents
	1. Introduction to SunForum�1
	2. Using SunForum�3
	3. SunForum Phone�37
	4. Configuring Gateway Software�47
	5. SunForum on a Sun Ray System�51
	6. Technical Information�55

	Figures
	Tables
	Preface


	How This Book Is Organized
	Using UNIX Commands
	Typographic Conventions
	Shell Prompts
	Accessing Sun Documentation Online
	Ordering Sun Documentation
	Sun Welcomes Your Comments
	1
	Introduction to SunForum

	SunForum Features
	Online Help
	2
	Using SunForum

	SunForum Basics
	To Start the SunForum Software
	FIGURE�2�1 My Information Window
	FIGURE�2�2 SunForum 3.2 Conference Manager


	SunForum Menus
	Call Menu
	TABLE�2�1 Call Menu

	View Menu
	TABLE�2�2 View Menu�

	Tools Menu
	TABLE�2�3 Tools Menu�

	Options Menu
	TABLE�2�4 Options Menu�

	Help Menu

	Using Directories
	To Change Your Directory Information
	1. Choose Call ‰ Change My Information.
	2. Fill in the following fields:
	3. Change the details as required and click OK.

	To Log In to a Directory Server
	1. To view the directory listing, choose Call ‰ Log On To Directory Server.
	2. Type the name of the directory server you want to log in to and click OK.

	To Log Out From a Directory Server
	To Refresh the Directory List
	To Automatically Log In to a Directory Server at Startup
	1. Choose Call ‰ Change My information.
	2. Select “At startup, log on to the directory server.”
	3. Specify the directory server name in the Server Name field.
	4. Type the name of the directory server you want to log in to in the Server Name field.

	To Remove Your Name From the Directory Server
	1. Choose Call ‰ Change My Information.
	2. Select “Do not list my name when logged on to the directory server.”

	To Call a User in the Directory List
	To Call a User on a Directory Server Using an Email Address

	Using the SunForum Software
	Making a Call
	To Make a Quick Connection
	1. Choose View ‰ Address Book, or click the Address Book button.
	2. Double-click on the address book entry that you want to connect to.

	To Connect Manually
	1. Choose Call ‰ Place Call, or click the Call button.
	2. Type the address with which you want to conference.
	3. Click OK.

	To End a Connection

	Sharing Applications
	To Share Applications
	1. While in a conference call, choose Tools ‰ Share, or click the Share button.
	2. Place your mouse pointer (now a hand symbol) over the desktop application window you want to s...
	3. Click anywhere in that application window.

	To Unshare Applications
	1. Choose Tools ‰ Unshare, or double-click Unshare, to stop sharing the application.
	2. Click on the application window that was being shared.

	To Collaborate Applications
	1. Share an application (see To Share Applications).
	2. Choose Tools ‰ Collaborate, or click Collaborate.

	To Transfer Files
	1. Choose Tools ‰ Send File, or click Send File.
	2. Go to the directory and select the file you want to send.
	3. Click OK.

	To Chat
	1. Choose Tools ‰ Chat, or click the Chat button to start the chat application.
	2. Select the recipient of your message.
	3. Type your message in the message field and press Return.

	To Transfer Data Using the Shared Clipboard
	1. Ensure that Shared Clipboard is enabled on both systems.
	2. Choose Tools ‰ Shared Clipboard.
	3. Select text from an application (for example, a Command Tool) on one system.
	4. Choose Edit ‰ Copy.
	5. In an application (for example, a text editor) on another system, choose Edit ‰ Paste.



	Using the SunForum Audio and Video
	Types of Audio/Video Conferences
	FIGURE�2�3 Conference Manager Audio and Video Icons

	Configuring Audio and Video Capabilities
	To Set Audio/Video Options
	TABLE�2�5 Audio and Video Options�

	To Set Audio/Video Device Options
	TABLE�2�6 Audio and Video Device Options

	Using the Sun 1394 Camera Snap Feature

	Controlling Audio Within the Conference
	To Adjust Your Audio Over a Conference
	To Adjust Conference Audio on Your Computer
	Controlling Your Video Image Over a Conference
	To Control Your Video Image Before a Conference

	To Control Your Video Image During a Conference
	Controlling Video Image Within a Multipoint Conference
	To Control Video Image Within a Multipoint Conference

	Controlling Video Within a Point-To-Point Conference
	To Switch to Another Person

	Displaying Remote Video in a Point-To-Point Conference
	To Display Remote Video


	Using the SunForum Whiteboard
	To Select a Whiteboard Mode
	1. Choose Options ‰ Tool Settings.
	2. Choose the desired whiteboard mode: T.126 or SunForum 1.0 mode.
	3. Click OK.

	To Start the Whiteboard
	FIGURE�2�4 SunForum 3.2 Whiteboard

	Whiteboard Menus
	TABLE�2�7 Whiteboard Menu Bar Descriptions�

	Whiteboard Tool Panel
	FIGURE�2�5 Whiteboard Tool Panel
	To Draw Graphical Objects
	1. Click the tool type in the whiteboard tool panel.
	2. Choose your pen color and line thickness.
	a. Click the Whiteboard Options button located on the bottom of the whiteboard.
	FIGURE�2�6 Whiteboard Options Button
	FIGURE�2�7 Whiteboard Options Panel

	b. Choose your pen color and pen width, then click OK.

	3. Click and drag your mouse button to draw the object.


	To Use Text Objects
	Creating Text Objects
	1. Click the Text tool button, or choose Tools ‰ Text.
	2. Place your mouse pointer in the whiteboard where you want to enter text.
	3. Click at that location.
	4. Enter the text and click OK.

	Editing Text Objects
	1. Click the Text tool button, or choose Tool ‰ Text.
	2. Click the text in your whiteboard that you want to edit.
	3. Edit the text and click OK.

	Setting the Font and Style of Text Objects
	1. Click the Whiteboard Option button.
	2. Click the Text Font, Text Size, and Text Style menus and choose the font setting.
	3. Click OK on the Whiteboard Options window.

	To Move and Delete Objects
	1. Click the Selector tool button, or choose Tools ‰ Selector.
	2. Click the graphic or text that you want to move or delete.
	a. To move the graphic or text, drag it with the mouse pointer to its new position.
	b. To delete the graphic or text, press Delete on your keyboard, or choose Edit ‰ Delete.


	To Highlight Text and Images
	1. Click the Highlight button, or choose Tools ‰ Highlighter.
	2. Draw on the whiteboard area you want to highlight.


	Capturing and Copying Video Images
	To Capture an Image from the Whiteboard Tools Panel
	1. Select the camera video image you wish to capture.
	2. Click the Snap My Video from the Whiteboard tools panel (see FIGURE�2�5), or choose Tools ‰ Sn...

	To Capture an Image Using the Sun 1394 Camera
	1. Click the Enable Camera button on the whiteboard tools panel (see FIGURE�2�5).
	2. Focus on the image to be captured and press the Sun 1394 Camera snap button.


	To Add Screen Captures to the Whiteboard
	Selecting and Capturing a Window
	1. Click the Select window button, or choose Tools ‰ Select Window.
	2. Place the mouse pointer on the window you want to add to your whiteboard.
	3. Click the window.

	Selecting and Capturing an Area of the Screen
	1. Click the Select window button, or choose Tools ‰ Select Area.
	2. Drag the mouse pointer over the area of your desktop screen that you want to capture.

	To Import Graphics
	1. Choose File ‰ Import.
	2. Specify the file you want to import and click OK.

	To Export Graphics
	1. Choose File ‰ Export.
	2. Specify the file you want to export.
	3. Choose an image format from the Save file as type menu.
	4. Click OK.

	To Use the Remote Pointer
	1. Click the Remote Pointer button, or choose Tools ‰ Remote Pointer.
	2. Click and drag the remote pointer to move to selected areas of interest.

	To Use Whiteboard Stamps
	1. Click the rubber stamp button.
	FIGURE�2�8 Rubber Stamps Button
	FIGURE�2�9 Whiteboard Stamps Window

	2. Click on a stamp image and click OK.
	3. Place the stamp pointer in the whiteboard where you want the image to appear and click.


	To Copy to the Clipboard
	Using the Quick Method to Copy Text
	1. Select text in the whiteboard (or another text source window) or from another application.
	2. Place the mouse pointer in the whiteboard and click the middle mouse button to paste the text ...

	Using the Edit Commands
	1. Select the text or object you want to copy.
	2. Choose Edit ‰ Cut or Edit ‰ Copy.
	3. Go to a new whiteboard page and choose Edit ‰ Paste.

	To Navigate and Organize Pages
	To Add a New Page
	FIGURE�2�10 New Page Button

	To Zoom the Whiteboard
	To Lock the Whiteboard
	1. Click the Lock button, or choose Tools ‰ Lock.
	2. Click the lock button a second time to release the lock.

	To Save the Whiteboard Contents to a File
	To Print the Whiteboard Contents
	FIGURE�2�11 Print Button
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	Starting the SunForum Phone
	FIGURE�3�1 SunForum Phone

	SunForum Phone Menus
	Call Menu
	TABLE�3�1 Call Menu

	Controls Menu
	TABLE�3�2 Controls Menu�

	Address Book Menu
	TABLE�3�3 Address Book Menu

	Help Menu

	Using the SunForum Phone
	Placing a Call
	To Place a Call Through the Phone Interface
	FIGURE�3�2 Placing a Call

	To Clear a Number That You Have Entered
	To Turn On the Phone Microphone


	My Video
	1. Double click the My Video button (FIGURE�3�2) next to your name in the Name field. See FIGURE�...
	2. From the My Video menu bar, choose View ‰ Audio/Video Settings.
	TABLE�3�4 Audio and Video Settings�


	Audio and Video Device Settings
	To Set Audio/Video Device Options
	TABLE�3�5 Audio and Video Device Options


	Media Configuration Wizard
	1. Choose Controls ‰ Media Configuration Wizard from the Phone menu bar.
	2. Click Next at each window to progress through the configuration pages (TABLE�3�6).
	3. Click Finish on the last page when done.
	TABLE�3�6 Media Configuration Wizard


	Preferences
	FIGURE�3�3 SunForum Phone Preferences Window
	TABLE�3�7 SunForum Phone Preferences
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	Configuring Gateway Software

	Overview
	Gateway Configuration File
	1. Become superuser in a shell window.
	2. Go to the SunForum configuration directory:
	3. Open the SunForum system configuration file:
	4. Locate the gateway settings portion of the configuration file and type the required information.
	5. Save the file, exit superuser, and start SunForum Phone (see Chapter�3 “SunForum Phone”).
	6. Toggle Gateway Mode from the Controls menu.
	FIGURE�4�1 SunForum Phone GUI in Gateway PBX Mode


	Using SunForum Phone Gateway
	FIGURE�4�2 Gateway Network Example of Systems Running SunForum 3.2
	1. Start SunForum Phone.
	2. Update the SunForum system configuration file.
	3. Choose Controls ‰ Gateway Mode.
	FIGURE�4�3 Gateway Mode

	4. In the Call edit field (FIGURE�4�3), enter the number you are calling.
	5. Press Return, or click the Place Call button, to make the connection.
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	SunForum on a Sun Ray System

	Sun Ray Requirements
	Sun Ray Libraries

	Sun Gatekeeper Software
	Overview
	Starting Sun Gatekeeper
	1. Decide which server will start the gatekeeper software.
	2. Become superuser.
	3. Start Sun gatekeeper. Type:

	Editing the System Configuration File
	1. Become superuser.
	2. Go to your system configuration file:
	3. Change the configuration file default settings.
	4. To view who is registered in the gatekeeper, type:
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	FIGURE�6�1 T.120 Conference Hierarchy

	SunForum’s Whiteboard and Compatibility Mode
	Using the SunForum Software Through a Network Security Mechanism
	Using TrueType Fonts With SunForum Software
	Calling Into a Multipoint Control Unit
	Calling Into Password-Protected Conferences
	Optimizing Video Display
	1. Add the following line to the /etc/system file:
	2. Reboot your system.
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