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Legato Systems, Inc. End-User License Agreement
THIS PRODUCT CONTAINS CERTAIN COMPUTER PROGRAMS AND OTHER PROPRIETARY MATERIAL, THE USE OF WHICH IS SUBJECT TO THIS
END-USER LICENSE AGREEMENT (THE “AGREEMENT”). DO NOT PROCEED WITH THE INSTALLATION OF THIS PRODUCT UNTIL YOU (LATER
DEFINED AS LICENSEE) HAVE READ THIS AGREEMENT AND AGREE TO BE BOUND BY AND BECOME A PARTY TO THIS AGREEMENT. BY
PROCEEDING WITH THE INSTALLATION OF THIS PRODUCT (OR AUTHORIZING ANY OTHER PERSON TO DO SO), YOU AND YOUR COMPANY
ACCEPT THIS AGREEMENT AND YOU REPRESENT THAT YOU ARE AUTHORIZED TO DO SO. IF YOU ARE ACCESSING THE PRODUCT
ELECTRONICALLY INDICATE YOUR ACCEPTANCE OF THESE TERMS BY SELECTING THE “ACCEPT” BUTTON AT THE END OF THE AGREEMENT.
IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, YOU MAY RETURN THIS PRODUCT, ALL MEDIA AND DOCUMENTATION, AND
PROOF OF PAYMENT, TO THE PLACE YOU OBTAINED THEM FOR A FULL REFUND WITHIN THIRTY (30) DAYS OF FIRST ACQUIRING THIS
PRODUCT OR, IF THE PRODUCT IS ACCESSED ELECTRONICALLY, SELECT THE “DECLINE” BUTTON AT THE END OF THIS AGREEMENT AND
RETURN PROOF OF PAYMENT IN ACCORDANCE WITH THE ABOVE REFERENCED RETURN/REFUND PROCESS. WRITTEN APPROVAL IS NOT A
PREREQUISITE TO THE VALIDITY OR ENFORCEABILITY OF THIS AGREEMENT AND NO SOLICITATION OF ANY SUCH WRITTEN APPROVAL BY
OR ON BEHALF OF LEGATO SHALL BE CONSTRUED AS AN INFERENCE TO THE CONTRARY. IF YOU HAVE ORDERED THIS PRODUCT, LEGATO’S
ACCEPTANCE IS EXPRESSLY CONDITIONAL ON YOUR ASSENT TO THESE TERMS TO THE EXCLUSION OF ALL OTHER TERMS; IF THESE TERMS
ARE CONSIDERED AN OFFER BY LEGATO, ACCEPTANCE IS EXPRESSLY LIMITED TO THESE TERMS.

1. DEFINITIONS

1.1 Authorization Code: means the code provided to Licensee by Legato for
permanent authorization to use the Software. The Authorization Code is
provided to Licensee once the Enabler Code is registered with Legato.

1.2 Documentation: means any user reference materials on any media,
provided by Legato for use with the Software.

1.3 Enabler Code: means the code provided by Legato for activation of the
Software.

1.4 Licensee: means the person or entity acquiring this License or for whom
this License was acquired.

1.5 Software: means the object code copy of the software program provided
to You in association with this Agreement, together with the associated
original electronic media and all accompanying manuals and other
documentation, and together with all enhancements, upgrades, and
extensions thereto that may be provided by Legato to You from time to time.

2. OWNERSHIP AND ADMINISTRATION OF SOFTWARE

2.1 Ownership and Title. As between the parties, Legato, and its licensors,
own and shall retain all right, title, and interest in and to: (i) the Software
including all intellectual property rights embodied therein; (ii) all of the
service marks, trademarks, trade names, or any other designations associated
with the Software; and (iii) all copyrights, patent rights, trade secret rights,
and other proprietary rights relating to the Software.

2.2 Software Activation. Legato employs Enabler Codes and Authorization
Codes that enable the use of the Software.   The Software is shipped in a
"Media Kit" which consists of object code software on CD-ROM and an
Enabler Code for initial activation of the Software or the Software and
Enabler Code may be delivered electronically. Once Legato receives
confirmation from Licensee that the Enabler Code is installed and is provided
with the host ID information, Legato will provide the Authorization Code to
Licensee. Legato administers the generation and distribution of Enabler and
Authorization Codes, which administration may be modified by Legato from
time to time.

2.3 Administration of Software. Legato may include on the media with the
Software additional computer programs which are not currently licensed for
use by Licensee and to which the Enabler Code or Authorization code will not
permit access. Inclusion of such additional computer programs in no way
implies a license from Legato and access or use of such programs is strictly
prohibited unless Licensee procures the right to use any such program and
the applicable Enabler Code is provided thereto.

3. LICENSE GRANT

3.1 Grant. Legato grants to Licensee a nonexclusive, nontransferable,
nonsublicensable, perpetual, unless terminated in accordance with the
provisions of this Agreement, license (the “License”) to (i) use the Software
installed in accordance with the Documentation and only on the licensed
computer solely for its own internal operations; and (ii) move the Software
temporarily in case of computer system malfunction. The License granted
under this Agreement does not constitute a sale of the Software or any
portion or copy of it. Licensee may not use the Software on more than one
computer system unless otherwise specifically authorized by an explicit
Software product, or additional licenses for additional computers are
purchased. Rights not expressly granted are reserved by Legato. Where the
Software is provided to Licensee at no charge for evaluation purposes only,
the License granted is limited to a continuous thirty (30) day period,
commencing with the acceptance of this Agreement (the "Evaluation
Period"). At the conclusion of the Evaluation Period, Licensee agrees to
destroy the Software and certify its destruction to Legato, in writing, within
ten (10) days, or shall return the Software to Legato or purchase a perpetual
license.

3.2 Copies. Licensee may make copies of the Software provided that any such
copy is: (i) created as an essential step in utilization of the Software on the
licensed computer and is used in no other manner; or (ii) used for archival
purposes to back up the licensed computers. All trademark and copyright
notices must be reproduced and included on such copies. Licensee may not
make any other copies of the Software.

3.3 Restrictions on use. Licensee shall not, and shall not aid, abet, or permit
any third party to: (i) decompile, disassemble, or otherwise reverse engineer
or attempt to reconstruct or discover any source code or underlying ideas or
algorithms of the Software by any means whatsoever; (ii) remove any
identification, copyright, or other notices from the Software; (iii) provide,
lease, lend, use for timesharing or service bureau purposes; (iv) create a
derivative work of any part of the Software; or (v) develop methods to enable
unauthorized parties to use the Software. If EC law is applicable, the
restrictions in Section 3.3 (i) are limited so that they prohibit such activity only
to the maximum extent such activity may be prohibited without violating the
EC Directive on the legal protection of computer programs. Notwithstanding
the foregoing, prior to decompiling, disassembling, or otherwise reverse
engineering any of the Software, Licensee shall request Legato in writing, to
provide Licensee with such information or assistance and Licensee shall
refrain from decompiling, disassembling, or otherwise reverse engineering
any of the Software unless Legato cannot or has not complied with such
request in a commercially reasonable amount of time.

3.4 Purchase Orders. Nothing contained in any purchase order,
acknowledgment, or invoice shall in any way modify the terms or add any
additional terms or conditions to this Agreement.

3.5 Updates. This section applies if the Software acquired is an update to the
original Software (the “Update”). An Update does not constitute a legally
licensed copy of the Software unless purchased as an Update to a previous
version of the same Software. The Update may only be used in accordance
with the provisions of this Agreement. The Update, together with the original
Software, constitutes one (1) legally licensed copy of the Software.

3.6 Evaluation License. This Section applies if the Software is being used for
an initial thirty (30) day evaluation period. The license is valid only for a
period of thirty (30) days from the delivery of the Software, and is designed
to allow Licensee the right to evaluate the Software during such period. In the
event that Licensee desires to enter into a longer-term license agreement with
Legato, Licensee shall obtain an appropriate Enabler and Authorization Code
in accordance with Section 2.2 above, upon payment of applicable fees, which
authorizes use of the Software after such evaluation period, but only subject
to all of the terms and conditions of this Agreement. In the event Licensee
determines not to enter into a licensing transaction with Legato at the end of
such thirty (30) day evaluation period, then Licensee’s rights under this
Agreement shall terminate automatically and Licensee shall promptly return
to Legato or destroy all copies of the Software and so certify to Legato.

4. MAINTENANCE AND SUPPORT

4.1 Legato has no obligation to provide support, maintenance, upgrades,
modifications, or new releases under this Agreement. Legato may provide
such services under separate agreement.

5. LIMITED WARRANTY

5.1 Media and Documentation. Legato warrants that if the media or
documentation are damaged or physically defective at the time of delivery of
the first copy of the Software to Licensee and if defective or damaged product
is returned to Legato (postage prepaid) within thirty (30) days thereafter, then
Legato will provide Licensee with replacements at no cost.

5.2 Limited Software Warranty. Subject to the conditions and limitations of
liability stated herein, Legato warrants for a period of thirty (30) days from
the delivery of the first copy of the Software to Licensee that the Software, as
delivered, will materially conform to Legato’s then current published
Documentation for the Software. This warranty covers only problems



reported to Legato during the warranty period. For customers outside of the
United States, this Limited Software Warranty shall be construed to limit the
warranty to the minimum warranty required by law.

5.3 Remedies. The remedies available to Licensee hereunder for any such
Software which does not perform as set out herein shall be either repair or
replacement, or, if such remedy is not practicable in Legato’s opinion, refund
of the license fees paid by Licensee upon a return of all copies of the Software
to Legato.   In the event of a refund this Agreement shall terminate
immediately without notice

6. TERM AND TERMINATION

6.1 Term. The term of this Agreement is perpetual unless terminated in
accordance with its provisions.

6.2 Termination. Legato may terminate this Agreement, without notice, upon
Licensee’s breach of any of the provisions hereof.

6.3 Effect of Termination. Upon termination of this Agreement, Licensee
agrees to cease all use of the Software and to return to Legato or destroy the
Software and all Documentation and related materials in Licensee’s
possession, and so certify to Legato. Except for the License granted herein
and as expressly provided herein, the terms of this Agreement shall survive
termination.

7. DISCLAIMER AND LIMITATIONS

7.1 Warranty Disclaimer. EXCEPT FOR THE LIMITED WARRANTY
PROVIDED IN SECTION 5 ABOVE, LEGATO AND ITS LICENSORS MAKE
NO WARRANTIES WITH RESPECT TO ANY SOFTWARE AND
DISCLAIMS ALL STATUTORY OR IMPLIED WARRANTIES, INCLUDING
WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR ARISING FROM A COURSE
OF DEALING OR USAGE OF TRADE AND ANY WARRANTIES OF
NONINFRINGEMENT. ALL SOFTWARE IS PROVIDED “AS IS” AND
LEGATO DOES NOT WARRANT THAT THE SOFTWARE WILL MEET ANY
REQUIREMENTS OR THAT THE OPERATION OF SOFTWARE WILL BE
UNINTERRUPTED OR ERROR FREE. ANY LIABILITY OF LEGATO WITH
RESPECT TO THE SOFTWARE OR THE PERFORMANCE THEREOF
UNDER ANY WARRANTY, NEGLIGENCE, STRICT LIABILITY OR OTHER
THEORY WILL BE LIMITED EXCLUSIVELY TO THE REMEDIES
SPECIFIED IN SECTION 5.3 ABOVE. Some jurisdictions do not allow the
exclusion of implied warranties or limitations on how long an implied
warranty may last, so the above limitations may not be applicable.

8. LIMITATION OF LIABILITY

8.1 Limitation of Liability. EXCEPT FOR BODILY INJURY, LEGATO (AND
ITS LICENSORS) WILL NOT BE LIABLE OR RESPONSIBLE WITH
RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT UNDER
ANY CONTRACT, NEGLIGENCE, STRICT LIABILITY, OR OTHER LEGAL
OR EQUITABLE THEORY FOR: (I) ANY INDIRECT, SPECIAL,
INCIDENTAL OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED
AND WHETHER OR NOT ADVISED IN ADVANCE OF THE POSSIBILITY
OF SUCH DAMAGES; OR (II) DAMAGES FOR LOST PROFITS OR LOST
DATA; OR (III) COST OF PROCUREMENT OF SUBSTITUTE GOODS,
TECHNOLOGY, SERVICES, OR RIGHTS; OR FOR AMOUNTS IN EXCESS
OF THOSE RECEIVED BY LEGATO FOR THE PARTICULAR LEGATO
SOFTWARE THAT CAUSED THE LIABILITY. Because some jurisdictions do
not allow the exclusion or limitation of incidental or consequential damages,
Legato's liability in such jurisdictions shall be limited to the extent permitted
by law.

9. MISCELLANEOUS

9.1 Governing Law. This Agreement shall be governed by the laws of the
State of California, as applied to agreements entered into and to be performed
entirely within California between California residents, without regard to the

principles of conflict of laws or the United Nations Convention on Contracts
for the International Sale of Goods.

9.2 Government Restricted Rights. This provision applies to Software
acquired directly or indirectly by or on behalf of any government. The
Software is a commercial software product, licensed on the open market at
market prices, and was developed entirely at private expense and without the
use of any government funds. All Software and accompanying
Documentation provided in connection with this Agreement are
“commercial items,” “commercial computer software,” and/or “commercial
computer software documentation.” Any use, modification, reproduction,
release, performance, display, or disclosure of the Software by any
government shall be governed solely by the terms of this Agreement and
shall be prohibited except to the extent expressly permitted by the terms of
this Agreement, and no license to the Software is granted to any government
requiring different terms. Licensee shall ensure that each copy used or
possessed by or for any government is labeled to reflect the foregoing.

9.3 Export and Import Controls. Regardless of any disclosure made by
Licensee to Legato of an ultimate destination of the Products, Licensee will
not directly or indirectly export or transfer any portion of the Software, or any
system containing a portion of the Software, to anyone outside the United
States (including further export if Licensee took delivery outside the U.S.)
without first complying with any export or import controls that may be
imposed on the Software by the U.S. Government or any country or
organization of nations within whose jurisdiction Licensee operates or does
business. Licensee shall at all times strictly comply with all such laws,
regulations, and orders, and agrees to commit no act which, directly or
indirectly, would violate any such law, regulation or order.

9.4 Assignment. This Agreement may not be assigned or transferred by
Licensee without the prior written consent of Legato, which shall not be
unreasonably withheld. Legato may assign or otherwise transfer any or all of
its rights and obligations under this Agreement upon notice to Licensee.

9.5 Sole Remedy and Allocation of Risk. Licensee's sole and exclusive
remedies are set forth in this Agreement. This Agreement defines a mutually
agreed-upon allocation of risk, and the License price reflects such allocation
of risk.

9.6 Equitable Relief. The parties agree that a breach of this Agreement
adversely affecting Legato’s intellectual property rights in the Software may
cause irreparable injury to Legato for which monetary damages may not be
an adequate remedy and Legato shall be entitled to equitable relief in
addition to any remedies it may have hereunder or at law.

9.7 No Waiver. Failure by either party to enforce any provision of this
Agreement will not be deemed a waiver of future enforcement of that or any
other provision, nor will any single or partial exercise of any right or power
hereunder preclude further exercise of any other right hereunder.

9.8 Severability. If for any reason a court of competent jurisdiction finds any
provision of this Agreement, or portion thereof, to be unenforceable, that
provision of the Agreement will be enforced to the maximum extent
permissible so as to effect the intent of the parties, and the remainder of this
Agreement will continue in full force and effect.

10. ENTIRE AGREEMENT

10.1 This Agreement sets forth the entire understanding and agreement
between the parties and may be amended only in a writing signed by
authorized representatives of both parties. No vendor, distributor, dealer,
retailer, sales person, or other person is authorized by Legato to modify this
Agreement or to make any warranty, representation, or promise which is
different than, or in addition to, the warranties, representations, or promises
made in this Agreement. No preprinted purchase order terms shall in any
way modify, replace, or supersede the terms of this Agreement.
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Preface

This Legato® Single Server Version Installation Guide, Release 6.1 provides instructions on
how to upgrade to, install, and uninstall the Legato Single Server Version release 6.1
software.

After installing the Legato Single Server Version software, refer to the Legato Single
Server Version Administrator’s Guide, Release 6.1 and the program’s online help for
detailed instructions on how to configure, administer, and use the Legato Single Server
Version software for Oracle data storage management.

Audience
The information in this guide is intended for system administrators and Oracle
database administrators (DBAs) who are responsible for installing and maintaining
Oracle Server backup and recovery systems. Operators who monitor the daily Oracle
database backups may also find this manual useful.

Effective use of this guide requires a working knowledge of Oracle concepts and
terminology, especially those related to Oracle database backup and recovery.

Product Documentation
Legato offers an extensive archive of product documentation at its web site
www.legato.com. Most of the documents are in Adobe Acrobat Portable Document
Format (PDF), and can be viewed by downloading and installing the Adobe Acrobat
Reader. The Reader is available directly from Adobe at www.adobe.com. To install and
use the Reader on the preferred platform, refer to the instructions at the Adobe web
site.
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Conventions
This document uses the following typographic conventions and symbols to make
information easier to access and understand.

Convention Indicates Example

boldface Names of line commands,
daemons, options,
programs, or scripts

The nsradmin command starts the
command line version of the administration
program.

italic in text Pathnames, filenames,
computer names, new terms
defined in the Glossary or
within the chapter, or
emphasized words

Displayed messages are also written to
/nsr/logs/daemon.log.

italic in command
line

A variable that must be
provided in the command
line

nwadmin -s server-name

fixed-width Examples and information
displayed on the screen

media waiting: recover waiting for
8mm 5GB tape volume name

fixed-width,
boldface

Commands and options that
must be typed exactly as
shown

nsr_shutdown -a

Menu_Name>
Command

A path or an order to follow
for making selections in the
GUI

Volume>Change Mode>Appendable

Important: Information that must be
read and followed to ensure
successful backup and
recovery of data

Important: Use the no_verify option with
extreme caution.
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Information and Services
Legato offers a variety of methods, including electronic, telephone, and fax support to
obtain company, product, and technical information.

General Information

The Legato web site provides most of the information that customers might need.
Technical bulletins and binary patches are also accessible on the Legato FTP site. For
specific sales or training needs, e-mail or call Legato.

Technical Support

The Support section of the Legato web site provides contact information, software
patches, technical documentation, and information about available support programs.

• Customers with an active support agreement have access to Legato’s integrated
product knowledge base. Help with Legato software issues is also available
through Legato Technical Support.

• Customers without an active support agreement can contact Support Sales and
Renewal to purchase annual Software Update Subscriptions, or Legato Technical
Support services for per-update/per-incident support.

Legato Service or
Resource

Technical
Bulletins

Binary
Patches

Company &
Product
Information

Training
Programs

www.legato.com Yes Yes Yes Yes

ftp.legato.com
(log in as anonymous)

Yes Yes

Legato Sales
(650) 210-7000 (option 1)
sales@legato.com

Yes

Legato Education Services
(650) 842-9357
training@legato.com

Yes
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Licensing and Registration

To license and register Legato products, go to the Legato licensing web site. To change
contact information, transfer licenses, or ask questions about licensing, contact Legato
using one of the following methods.

Customer Feedback
Legato welcomes comments and suggestions about software features, the installation
procedure, and documentation. Please send any suggestions and comments to
feedback@legato.com. Legato confirms receipt of all e-mail correspondence. Although
Legato cannot respond personally to every request, all comments and suggestions are
considered during product design.

Help improve Legato documentation by completing a brief survey. Visit the Legato
web site at www.legato.com, navigate to the documentation page, and click on the link
to the survey.

Licensing and Registration Contact

Legato licensing web site http://license.legato.com

Telephone number (650) 812 6000 (option 3, option 2)a

+31 23 554 8881b

a. Contact information for Americas, Asia, and Pacific.
b. Contact information for Europe, Middle East, and Africa.

Fax number (650) 745-1477a

+31 23 554 8808b

E-mail licensing@legato.coma

licensingemea@legato.comb
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Chapter 1: Introduction

This Legato Single Server Version Installation Guide, Release 6.1 describes how to install
and enable Legato Single Server Version release 6.1 software on a supported UNIX,
Windows 2000, or Windows NT (Intel) system running Oracle9i Server software.

The Legato Single Server Version software is distributed on the Oracle9i Server
software CD-ROM.

Note: The Legato Single Server Version documentation is available only from the
Legato web site at www.legato.com/LSSV.

Use the information in this guide to:

• Upgrade to Legato Single Server Version release 6.1 from one of the following
Legato Storage Manager releases:
– Release 5.5 on UNIX
– Release 5.7 on Windows

• Install Legato Single Server Version release 6.1 on a system that does not contain
existing Legato Storage Manager or Legato NetWorker® software.

• Uninstall the Legato Single Server Version release 6.1 software.

To perform these procedures on a specific platform, see the appropriate chapter:

• "Chapter 2: Installation Procedures on AIX" on page 13
• "Chapter 3: Installation Procedures on HP-UX" on page 18
• "Chapter 4: Installation Procedures on Linux" on page 24
• "Chapter 5: Installation Procedures on Solaris" on page 29
• "Chapter 6: Installation Procedures on Tru64 UNIX" on page 35
• "Chapter 7: Installation Procedures on Windows" on page 40

Installation and Configuration Options
The Legato Single Server Version software comprises a media management layer, as
required by Recovery Manager (RMAN) for Oracle9i database backups and restores
using tape storage. Legato Single Server Version is a restricted functionality version of
the latest Legato NetWorker and Legato NetWorker Module for Oracle products
available from Legato Systems, Inc.
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Legato Single Server Version must be installed on the Oracle Server host. Legato Single
Server Version works in conjunction with the Oracle Server for Oracle data storage
management. Together, the Legato Single Server Version and Oracle Server software
components provide a storage management solution for the Oracle9i data on a
supported UNIX, Windows 2000, or Windows NT (Intel) system.

The Legato Single Server Version Administrator program is a graphical user interface
for administering the Legato Single Server Version configuration. The Administrator
program is installed during the Legato Single Server Version installation on the Oracle
Server host.

Note: The Legato Single Server Version Administrator program can be installed and
run separately on a Windows computer, using the instructions in
"Chapter 7: Installation Procedures on Windows" on page 40. The Administrator
program cannot be installed separately on a UNIX computer.

There are two different ways to install Legato Single Server Version:

• Legato Single Server Version can be installed by using Oracle Installer and
selecting Legato Single Server Version through the Custom Installation option of
the Oracle9i Enterprise Edition or Oracle9i Standard Edition. For more
information on using Oracle Installer, refer to the Oracle9i Installation Guide.

• Legato Single Server Version can be installed manually without using Oracle
Installer. For more information on installing Legato Single Server Version
manually, see the appropriate chapter in this guide for a particular platform.

After installing Legato Single Server Version, the Oracle9i Server must be configured
as a client of Legato Single Server Version for backup and restore operations. For
information on configuration procedures, refer to the Legato Single Server Version
Administrator’s Guide, Release 6.1.
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Chapter 2: Installation Procedures on AIX

This chapter describes how to upgrade to, install, and uninstall Legato Single Server
Version release 6.1 on a supported AIX system. See the appropriate section:

• "Upgrading from Legato Storage Manager" on page 13
• "Installing Legato Single Server Version" on page 14
• "Uninstalling Legato Single Server Version" on page 17

Upgrading from Legato Storage Manager
To upgrade from Legato Storage Manager to Legato Single Server Version:

1. Uninstall Legato Storage Manager. See "How to Uninstall Legato Storage
Manager" on page 13.

2. Install Legato Single Server Version. See "Installing Legato Single Server Version"
on page 14.

How to Uninstall Legato Storage Manager

Legato Storage Manager cannot be uninstalled using Oracle Installer. Legato Storage
Manager must be uninstalled using the information in this section.

Important: The following procedure deletes the Legato Storage Manager index and
configuration files (and the /nsr directory). After using this procedure, it will not be
possible to restore from existing Legato Storage Manager backups.

Legato Single Server Version does not support the restore of Oracle data from Legato
Storage Manager backups.

To uninstall Legato Storage Manager:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Storage Manager for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner
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b. Enter the following commands to delete the required symbolic links:
$ cd $ORACLE_HOME/lib

$ rm liblsm.a

$ rm libobk.a

3. Log in as the root user:

# su root

4. Enter the following nsr_ize command to uninstall Legato Storage Manager:

# nsr_ize -r -s

When prompted whether to delete the Legato Storage Manager client index, media
index, and resource configuration files, enter [y].

Installing Legato Single Server Version
Legato Single Server Version is typically installed using Oracle Installer, by selecting
the Custom installation of the Oracle software and then selecting the Legato Single
Server Version option. If Legato Single Server Version is not installed using Oracle
Installer, the software can be installed manually using the instructions in this section.

Before installing Legato Single Server Version, uninstall any existing Legato Storage
Manager or Legato NetWorker software on the system. If existing Legato software is
not detected during the Legato Single Server Version installation, both the existing
Legato software and the Legato Single Server Version software might not function
properly.

• To uninstall existing Legato Storage Manager release 5.5, see "Upgrading from
Legato Storage Manager" on page 13.

Note: To uninstall Legato Storage Manager prior to release 5.5, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.

How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Verify that there is sufficient disk space for each of the Legato Single Server Version
software components, as shown in Table 1 on page 14.

Note: The requirements in Table 1 apply to a default Legato Single Server Version
installation, without relocation of the software components.

Table 1. Legato Single Server Version Requirements on AIX (Part 1 of 2)

Components Default Location Space Requirement

Software binary files /bin 45 MB

Device drivers /etc/LGTOuscsi 1 MB
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2. Make copies of the following operating system files, which are modified by the
Legato Single Server Version installation script in step 6.

/etc/inittab

/etc/rc.nsr

/etc/rpc

/etc/syslog.conf

3. Log in as the root user:

# su root

4. Insert and mount the Oracle9i release CD-ROM in the appropriate device.

5. From the CD-ROM mount point, go to the stage/Components/lgto directory.

Note: If the Legato Single Server Version software is not located in the
stage/Components/lgto directory, the directory containing the software can be
located by entering the following command from the CD-ROM mount point:

find . -name lsminst -print

6. Enter the following lsminst command to install Legato Single Server Version:

# ./lsminst .

Enter the appropriate information at the lsminst prompts:
• When prompted whether to continue the installation, enter [y].
• When prompted for a directory to use for client and server information, either

accept the default (/nsr) or enter another directory name. Ensure that the
selected directory has sufficient disk space to store the online index files, as
listed in Table 1 on page 14.

• When prompted for a device name, either press [Enter] or enter a proper
BSD-semantics nonrewinding tape device name.

Note: Before Legato Single Server Version can use a device for Oracle backups
or restores, a Device resource must be configured for the device in the Legato
Single Server Version Administrator program. For more information, refer to
the Legato Single Server Version Administrator’s Guide, Release 6.1.

• At the following prompt, enter all, to enable backups using Legato Single
Server Version:
Enter the first NetWorker server’s name [no more]: all

• For all other lsminst prompts, press [Enter].

Online index files /nsr 100 MB

Online man pages /usr/man 1 MB

Table 1. Legato Single Server Version Requirements on AIX (Part 2 of 2)

Components Default Location Space Requirement
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7. Update the MANPATH and PATH environment variables.

• MANPATH must include the pathname of the directory containing the
Legato Single Server Version man pages. The default pathname is /usr/man, as
shown in Table 1 on page 14.

• PATH must include the pathname of the directory containing the Legato
Single Server Version software binaries. The default pathname is /bin, as
shown in Table 1 on page 14.

8. For each ORACLE_HOME that will use Legato Single Server Version for backups:

Note: If another ORACLE_HOME is later installed on the AIX system, follow these
steps to enable Legato Single Server Version backups for that ORACLE_HOME.

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Change to the stage/Components/lgto directory on the CD-ROM.
c. Enter the following cp command to copy the liblsm.a file to the

$ORACLE_HOME/lib directory:
$ cp ./lib/liblsm.a $ORACLE_HOME/lib/liblsm.a

d. Enter the following commands to create the required symbolic link:
$ cd $ORACLE_HOME/lib

$ ln -s liblsm.a libobk.a

9. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. Select Server>Registration to open the Registration window.
– If "Legato Single Server Version" appears in the Registration window,

Legato Single Server Version is properly enabled.
– If "NetWorker/10 Eval" or another name (other than "Legato Single

Server Version") appears in the Registration window, perform these steps
to enable Legato Single Server Version:
1. In the Registration window, click Create.
2. In the Enabler Code field, enter the following enabler code:

fa577c-a16e3f-d26553

3. Click Apply.

The following command and output can be used to verify that Legato Single Server
Version is installed properly:

# lslpp -l | grep -i legato

lus      6.1.0.0 COMMITTED Legato SCSI User Interface Tape

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using Legato Single Server Version. For
more information, refer to the Legato Single Server Version Administrator’s Guide, Release
6.1.
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Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.

Uninstalling Legato Single Server Version
Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Single Server Version for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Ensure that no Oracle backup or restore is running.
c. Enter the following commands to delete the required symbolic links:

$ cd $ORACLE_HOME/lib

$ rm liblsm.a

$ rm libobk.a

3. Log in as the root user:

# su root

4. Enter the following nsr_ize command to uninstall Legato Single Server Version:

# nsr_ize -r -s

When prompted whether to delete the Legato Single Server Version client index,
media index, and resource configuration files:
• Enter [n] to uninstall Legato Single Server Version without deleting the index

and configuration files.
• Enter [y] to uninstall Legato Single Server Version and delete the index and

configuration files (by deleting the /nsr directory).

Important: If the Legato Single Server Version index and configuration files (and the
/nsr directory) are deleted, existing Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.
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Chapter 3: Installation Procedures on HP-UX

This chapter describes how to upgrade to, install, and uninstall Legato Single Server
Version release 6.1 on a supported HP-UX system. See the appropriate section:

• "Upgrading from Legato Storage Manager" on page 18
• "Installing Legato Single Server Version" on page 19
• "Uninstalling Legato Single Server Version" on page 22

Upgrading from Legato Storage Manager
To upgrade from Legato Storage Manager to Legato Single Server Version:

1. Uninstall Legato Storage Manager. See "How to Uninstall Legato Storage
Manager" on page 18.

2. Install Legato Single Server Version. See "Installing Legato Single Server Version"
on page 19.

How to Uninstall Legato Storage Manager

Legato Storage Manager cannot be uninstalled using Oracle Installer. Legato Storage
Manager must be uninstalled using the information in this section.

Important: The following procedure deletes the Legato Storage Manager index and
configuration files (and the /nsr directory). After using this procedure, it will not be
possible to restore from existing Legato Storage Manager backups.

Legato Single Server Version does not support the restore of Oracle data from Legato
Storage Manager backups.

To uninstall Legato Storage Manager:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Storage Manager for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner
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b. Enter the following commands to delete the required symbolic links:
$ cd $ORACLE_HOME/lib

$ rm liblsm.sl

$ rm libobk.sl

3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Storage Manager
daemons:

# nsr_shutdown

5. Enter the following swremove command to uninstall Legato Storage Manager:

# swremove

6. In the Software Selection window, highlight Legato Storage Manager.

7. Select Actions>Remove (analysis).

8. In the Remove Analysis window, when the Status field changes to Ready, click
Logfile to check the log file. Correct any listed problems before proceeding.

9. Click OK.

10. In the Confirmation dialog box, click Yes.

11. In the Remove window, when the Status field changes to Completed, click Logfile
to check the log file. If any problems are listed, correct the problems and restart the
uninstall at step 3.

12. Click Done to exit the Remove window.

13. Select File>Exit to exit the Software Selection window.

14. Delete the /opt/networker directory manually, if required.

Note: The swremove program does not delete the /nsr directory containing the Legato
Storage Manager client index, media index, and resource configuration files.

15. To delete the Legato Storage Manager index and configuration files, enter the
following rm command to delete the /nsr directory:

# rm -rf /nsr/* /nsr

Installing Legato Single Server Version
Legato Single Server Version is typically installed using Oracle Installer, by selecting
the Custom installation of the Oracle software and then selecting the Legato Single
Server Version option. If Legato Single Server Version is not installed using Oracle
Installer, the software can be installed manually using the instructions in this section.

Before installing Legato Single Server Version, uninstall any existing Legato Storage
Manager or Legato NetWorker software on the system. If existing Legato software is
not detected during the Legato Single Server Version installation, both the existing
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Legato software and the Legato Single Server Version software might not function
properly.

• To uninstall existing Legato Storage Manager release 5.5, see "Upgrading from
Legato Storage Manager" on page 18.

Note: To uninstall Legato Storage Manager prior to release 5.5, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.

How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Verify that there is sufficient disk space for each of the Legato Single Server Version
software components, as shown in Table 2 on page 20.

Note: The requirements in Table 2 apply to a default Legato Single Server Version
installation, without relocation of the software components.

2. Make copies of the following operating system files, which are modified by the
Legato Single Server Version installation script in step 6.

/etc/rpc

/etc/syslog.conf

3. Log in as the root user:

# su root

4. Insert and mount the Oracle9i release CD-ROM in the appropriate device.

5. From the CD-ROM mount point, go to the stage/Components/lgto directory.

Note: If the Legato Single Server Version software is not located in the
stage/Components/lgto directory, the directory containing the software can be
located by entering the following command from the CD-ROM mount point:

find . -name lsminst -print

6. Enter the following lsminst command to install Legato Single Server Version:

# ./lsminst cd_mount_point/stage/Components/lgto

7. In the Software Selection window, highlight Legato Single Server Version.

Table 2. Legato Single Server Version Requirements on HP-UX

Components Default Location Space Requirement

Temporary space used by
the swinstall program

/tmp 25 MB

Software binary files /opt/networker/bin 150 MB

Online index files /nsr 100 MB

Online man pages /opt/networker/man 1 MB
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8. Select Actions>Install (analysis).

9. In the Install Analysis window, when the Status field changes to Ready, click
Logfile to check the log file. Correct any listed problems before proceeding.

Note: If an error appears in the log file stating that one or more filesystems in the
filesystem table cannot be mounted, perform these steps:

a. Verify with the site administrator that the filesystems listed in the /etc/fstab file
do not need to be mounted.

b. As the root user, enter the lsminst command from step 6 to restart the
installation.

c. In the Software Selection window, select Options>Change Options.
d. In the Options window, deselect the following option:

Mount filesystems in /etc/fstab or /etc/checklist

e. Click OK.
f. Restart at step 7.

10. In the Install Analysis window, click OK.

11. In the Confirmation dialog box, click Yes.

12. In the Install window, when the Status field changes to Completed, click Logfile to
check the log file. If any problems are listed, correct the problems and restart the
installation at step 5.

13. Click Done to exit the Install window.

14. Select File>Exit to exit the Software Selection window.

15. Update the MANPATH and PATH environment variables.

• MANPATH must include the pathname of the directory containing the
Legato Single Server Version man pages. The default pathname is
/opt/networker/man, as shown in Table 2 on page 20.

• PATH must include the pathname of the directory containing the Legato
Single Server Version software binaries. The default pathname is
/opt/networker/bin, as shown in Table 2 on page 20.

16. For each ORACLE_HOME that will use Legato Single Server Version for backups:

Note: If another ORACLE_HOME is later installed on the HP-UX system, follow
these steps to enable Legato Single Server Version backups for that
ORACLE_HOME.

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Change to the stage/Components/lgto directory on the CD-ROM.
c. Enter the following cp command to copy the liblsm.sl file to the

$ORACLE_HOME/lib directory:
$ cp ./lib/liblsm.sl $ORACLE_HOME/lib/liblsm.sl

d. Enter the following commands to create the required symbolic link:
$ cd $ORACLE_HOME/lib

$ ln -s liblsm.sl libobk.sl
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17. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. Select Server>Registration to open the Registration window.
– If "Legato Single Server Version" appears in the Registration window,

Legato Single Server Version is properly enabled.
– If "NetWorker/10 Eval" or another name (other than "Legato Single

Server Version") appears in the Registration window, perform these steps
to enable Legato Single Server Version:
1. In the Registration window, click Create.
2. In the Enabler Code field, enter the following enabler code:

fa577c-a16e3f-d26553

3. Click Apply.

The following command and output can be used to verify that Legato Single Server
Version is installed properly.

# /usr/sbin/swlist | grep -i lssv

NetWorker nw_lssv.Build.71 NetWorker for HP-UX 11.xx

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using the Legato Single Server Version
software. For more information, refer to the Legato Single Server Version Administrator’s
Guide, Release 6.1.

Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.

Uninstalling Legato Single Server Version
Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Single Server Version for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Ensure that no Oracle backup or restore is running.
c. Enter the following commands to delete the required symbolic links:

$ cd $ORACLE_HOME/lib

$ rm liblsm.sl

$ rm libobk.sl
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3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Single Server
Version daemons:

# nsr_shutdown

5. Enter the following swremove command to uninstall Legato Single Server Version:

# swremove

6. In the Software Selection window, highlight the name NetWorker.

7. Select Actions>Remove (analysis).

8. In the Remove Analysis window, when the Status field changes to Ready, click
Logfile to check the log file. Correct any listed problems before proceeding.

9. Click OK.

10. In the Confirmation dialog box, click Yes.

11. In the Remove window, when the Status field changes to Completed, click Logfile
to check the log file. If any problems are listed, correct the problems and restart the
uninstall at step 3.

12. Click Done to exit the Remove window.

13. Select File>Exit to exit the Software Selection window.

14. Delete the /opt/networker directory manually, if required.

Note: The swremove program does not delete the /nsr directory containing the Legato
Single Server Version client index, media index, and resource configuration files.

15. To delete the Legato Single Server Version index and configuration files (an optional
step), enter the following rm command to delete the /nsr directory:

# rm -rf /nsr/* /nsr

Important: If the Legato Single Server Version index and configuration files (and the
/nsr directory) are deleted, existing Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.
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Chapter 4: Installation Procedures on Linux

This chapter describes how to install and uninstall Legato Single Server Version release
6.1 on a supported Linux system. See the appropriate section:

• "Installing Legato Single Server Version" on page 24
• "Uninstalling Legato Single Server Version" on page 28

Installing Legato Single Server Version
Legato Single Server Version is typically installed using Oracle Installer, by selecting
the Custom installation of the Oracle software and then selecting the Legato Single
Server Version option. If Legato Single Server Version is not installed using Oracle
Installer, the software can be installed manually using the instructions in this section.

Before installing Legato Single Server Version, uninstall any existing Legato
NetWorker software on the system. If existing Legato NetWorker software is not
detected during the Legato Single Server Version installation, both the Legato
NetWorker software and the Legato Single Server Version software might not function
properly. To uninstall existing Legato NetWorker software, refer to the instructions in
the appropriate Legato NetWorker Installation Guide.

How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Verify that the specific Linux kernel is supported and that all the required Linux
packages and patches are installed, as shown in Table 3 on page 25.

Table 3 shows the platforms supported in this release of Legato Single Server
Version along with the package requirements for each of the operating system
installations. For more platform-specific information, consult the operating system
documentation, vendor, or other Linux documentation sources.
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2. Verify that there is sufficient disk space for each of the Legato Single Server Version
software components, as shown in Table 4 on page 25.

Note: The requirements in Table 4 apply to a default Legato Single Server Version
installation, without relocation of the software components.

Table 3. Linux System Software Requirements

Platform Kernel Additional Libraries or Upgrades

Red Hat
Advanced
Server
Edition 2.1

2.4.9-e.3 Upgrade the following packages:
• ncurses4-5.0-5.i386.rpm — available with the

installation media or at www.rpmfind.net (search for
ncurses4)

• pdksh-5.2.14-13.i386.rpm — available with the
installation media or at www.rpmfind.net (search for
pdksh)

Red Hat 7.1 2.4.2-2 Upgrade the following packages:
• ncurses4-5.0-5.i386.rpm — available with the

installation media or at www.rpmfind.net (search for
ncurses4)

• pdksh-5.2.14-12.i386.rpm — available with the
installation media or at www.rpmfind.net (search for
pdksh)

• rpm-build-4.0.3-0.66.i386.rpm
• rpm-devel-4.0.3-0.66.i386.rpm
• rpm-4.0.3-0.66.i386.rpm
• glibc-2.2.3-14.i386.rpm
• glibc-common-2.2.3-14.i386.rpm
• glibc-devel-2.2.3-14.i386.rpm

SuSE 7.1 2.4.0 Upgrade the pdksh-5.2.14-217.i386.rpm package,
available on the operating system installation media

Table 4. Legato Single Server Version Requirements on Linux

Components Default Location Space Requirement

GUI program files /usr/bin 11 MB

Daemon and utility command files /usr/sbin 29 MB

Device drivers /etc/LGTOuscsi 8 MB

Online index files /nsr 100 MB

Online man pages /usr/share/man 1 MB
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3. Make copies of the following operating system files, which are modified by the
Legato Single Server Version installation script in step 7.

/etc/rpc

/etc/syslog.conf

/etc/ld.so.conf

4. Log in as the root user:

# su root

5. Insert and mount the Oracle9i release CD-ROM in the appropriate device.

6. From the CD-ROM mount point, go to the stage/Components/lgto directory.

Note: If the Legato Single Server Version software is not located in the
stage/Components/lgto directory, the directory containing the software can be
located by entering the following command from the CD-ROM mount point:

find . -name lsminst -print

7. Enter the following lsminst command to install Legato Single Server Version:

# ./lsminst .

Enter the appropriate information at the lsminst prompts:
• When prompted whether to continue the installation, enter [y].
• When prompted for a directory to use for client and server information, either

accept the default (/nsr) or enter another directory name. Ensure that the
selected directory has sufficient disk space to store the online index files, as
listed in Table 4 on page 25.

• When prompted for a device name, either press [Enter] or enter a proper
BSD-semantics nonrewinding tape device name.

Note: Before Legato Single Server Version can use a device for Oracle backups
or restores, a Device resource must be configured for the device in the Legato
Single Server Version Administrator program. For more information, refer to
the Legato Single Server Version Administrator’s Guide, Release 6.1.

• At the following prompt, enter all, to enable backups using Legato Single
Server Version:
Enter the first NetWorker server’s name [no more]: all

• For all other lsminst prompts, press [Enter].

8. Update the MANPATH and PATH environment variables.

• MANPATH must include the pathname of the directory containing the
Legato Single Server Version man pages. The default pathname is
/usr/share/man, as shown in Table 4 on page 25.

• PATH must include the pathnames of the directories containing the Legato
Single Server Version program files. The default pathnames are /usr/bin and
/usr/sbin, as shown in Table 4 on page 25.
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9. For each ORACLE_HOME that will use Legato Single Server Version for backups:

Note: If another ORACLE_HOME is later installed on the Linux system, follow
these steps to enable Legato Single Server Version backups for that
ORACLE_HOME.

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Change to the stage/Components/lgto directory on the CD-ROM.
c. Enter the following cp command to copy the liblsm.so file to the

$ORACLE_HOME/lib directory:
$ cp ./lib/liblsm.so $ORACLE_HOME/lib/liblsm.so

d. Enter the following commands to create the required symbolic link:
$ cd $ORACLE_HOME/lib

$ ln -s liblsm.so libobk.so

10. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. Select Server>Registration to open the Registration window.
– If "Legato Single Server Version" appears in the Registration window,

Legato Single Server Version is properly enabled.
– If "NetWorker/10 Eval" or another name (other than "Legato Single

Server Version") appears in the Registration window, perform these steps
to enable Legato Single Server Version:
1. In the Registration window, click Create.
2. In the Enabler Code field, enter the following enabler code:

fa577c-a16e3f-d26553

3. Click Apply.

The following command and output can be used to verify that the Legato Single Server
Version is installed properly:

# rpm -aq | grep -i orcl

orclclnt-nw_lssv.build.71-1

orcldrvr-nw_lssv.build.71-1

orclnode-nw_lssv.build.71-1

orclserv-nw_lssv.build.71-1

orclman-nw_lssv.build.71-1

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using Legato Single Server Version. For
more information, refer to the Legato Single Server Version Administrator’s Guide,
Release 6.1.

Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.
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Uninstalling Legato Single Server Version
Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Single Server Version for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Ensure that no Oracle backup or restore is running.
c. Enter the following commands to delete the required symbolic links:

$ cd $ORACLE_HOME/lib

$ rm liblsm.so

$ rm libobk.so

3. Log in as the root user:

# su root

4. Enter the following rpm command to uninstall Legato Single Server Version:

# rpm -e orclman-nw_lssv.build.71-1 orclserv-nw_lssv.build.71-1
orclnode-nw_lssv.build.71-1 orcldrvr-nw_lssv.build.71-1
orclclnt-nw_lssv.build.71-1

Note: The rpm program does not delete the /nsr directory containing the Legato
Single Server Version client index, media index, and resource configuration files.

5. To delete the Legato Single Server Version index and configuration files (an optional
step), enter the following rm command to delete the /nsr directory:

# rm -rf /nsr/* /nsr

Important: If the Legato Single Server Version index and configuration files (and the
/nsr directory) are deleted, existing Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.
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Chapter 5: Installation Procedures on Solaris

This chapter describes how to upgrade to, install, and uninstall Legato Single Server
Version release 6.1 on a supported Solaris system. See the appropriate section:

• "Upgrading from Legato Storage Manager" on page 29
• "Installing Legato Single Server Version" on page 30
• "Uninstalling Legato Single Server Version" on page 33

Upgrading from Legato Storage Manager
To upgrade from Legato Storage Manager to Legato Single Server Version:

1. Uninstall Legato Storage Manager. See "How to Uninstall Legato Storage
Manager" on page 29.

2. Install Legato Single Server Version. See "Installing Legato Single Server Version"
on page 30.

How to Uninstall Legato Storage Manager

Legato Storage Manager cannot be uninstalled using Oracle Installer. Legato Storage
Manager must be uninstalled using the information in this section.

Important: The following procedure deletes the Legato Storage Manager index and
configuration files (and the /nsr directory). After using this procedure, it will not be
possible to restore from existing Legato Storage Manager backups.

Legato Single Server Version does not support the restore of Oracle data from Legato
Storage Manager backups.

To uninstall Legato Storage Manager:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Storage Manager for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner
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b. Enter the following commands to delete the required symbolic links:
$ cd $ORACLE_HOME/lib

$ rm liblsm.so

$ rm libobk.so

3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Storage Manager
daemons:

# nsr_shutdown

5. Enter the following pkgrm command to uninstall Legato Storage Manager:

# pkgrm ORCLserv ORCLnode ORCLman ORCLdrvr ORCLclnt

At each prompt that pkgrm displays, press [Enter].

Note: The pkgrm program does not delete the /nsr directory containing the Legato
Storage Manager client index, media index, and resource configuration files.

6. To delete the Legato Storage Manager index and configuration files, enter the
following rm command to delete the /nsr directory:

# rm -rf /nsr/* /nsr

Installing Legato Single Server Version
Legato Single Server Version is typically installed using Oracle Installer, by selecting
the Custom installation of the Oracle software and then selecting the Legato Single
Server Version option. If Legato Single Server Version is not installed using Oracle
Installer, the software can be installed manually using the instructions in this section.

Before installing Legato Single Server Version, uninstall any existing Legato Storage
Manager or Legato NetWorker software on the system. If existing Legato software is
not detected during the Legato Single Server Version installation, both the existing
Legato software and the Legato Single Server Version software might not function
properly.

• To uninstall existing Legato Storage Manager release 5.5, see "Upgrading from
Legato Storage Manager" on page 29.

Note: To uninstall Legato Storage Manager prior to release 5.5, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.
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How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Verify that there is sufficient disk space for each of the Legato Single Server Version
software components, as shown in Table 5 on page 31.

Note: The requirements in Table 5 on page 31 apply to a default Legato Single
Server Version installation, without relocation of the software components.

2. Make copies of the following operating system files, which are modified by the
Legato Single Server Version installation script in step 6.

/etc/rpc

/etc/syslog.conf

3. Log in as the root user:

# su root

4. Insert and mount the Oracle9i release CD-ROM in the appropriate device.

5. From the CD-ROM mount point, go to the stage/Components/lgto directory.

Note: If the Legato Single Server Version software is not located in the
stage/Components/lgto directory, the directory containing the software can be
located by entering the following command from the CD-ROM mount point:

find . -name lsminst -print

6. Enter the following lsminst command to install Legato Single Server Version:

# ./lsminst .

Enter the appropriate information at the lsminst prompts:
• When prompted whether to continue the installation, enter [y].
• When prompted for a directory to use for client and server information, either

accept the default (/nsr) or enter another directory name. Ensure that the
selected directory has sufficient disk space to store the online index files, as
listed in Table 5 on page 31.

Table 5. Legato Single Server Version Requirements on Solaris

Components Default Location Space Requirement

GUI program files /usr/bin 23 MB

Daemon and utility command
files

/usr/sbin 22 MB

Device drivers /etc/LGTOuscsi
/usr/kernel
/usr/lib/nsr

21 MB

Online index files /nsr 100 MB

Online man pages /usr/man 1 MB
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• When prompted for a device name, either press [Enter] or enter a proper
BSD-semantics nonrewinding tape device name.

Note: Before Legato Single Server Version can use a device for Oracle backups
or restores, a Device resource must be configured for the device in the Legato
Single Server Version Administrator program. For more information, refer to
the Legato Single Server Version Administrator’s Guide, Release 6.1.

• At the following prompt, enter all, to enable backups using Legato Single
Server Version:
Enter the first NetWorker server’s name [no more]: all

• For all other lsminst prompts, press [Enter].

7. Update the MANPATH and PATH environment variables.

• MANPATH must include the pathname of the directory containing the
Legato Single Server Version man pages. The default pathname is
/usr/share/man, as shown in Table 5 on page 31.

• PATH must include the pathnames of the directories containing the Legato
Single Server Version software binaries. The default pathnames are /usr/bin
and /usr/sbin, as shown in Table 5 on page 31.

8. For each ORACLE_HOME that will use Legato Single Server Version for backups:

Note: If another ORACLE_HOME is later installed on the Solaris system, follow
these steps to enable Legato Single Server Version backups for that
ORACLE_HOME.

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Change to the stage/Components/lgto directory on the CD-ROM.
c. Enter the following cp command to copy the liblsm.so file to the

$ORACLE_HOME/lib directory:
$ cp ./lib/liblsm.so $ORACLE_HOME/lib/liblsm.so

d. Enter the following commands to create the required symbolic link:
$ cd $ORACLE_HOME/lib

$ ln -s liblsm.so libobk.so

9. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. Select Server>Registration to open the Registration window.
– If "Legato Single Server Version" appears in the Registration window,

Legato Single Server Version is properly enabled.
– If "NetWorker/10 Eval" or another name (other than "Legato Single

Server Version") appears in the Registration window, perform these steps
to enable Legato Single Server Version:
1. In the Registration window, click Create.
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2. In the Enabler Code field, enter the following enabler code:
fa577c-a16e3f-d26553

3. Click Apply.

The following command and output can be used to verify that Legato Single Server
Version is installed properly:

# pkginfo | grep -i LSSV

application ORCLclnt      LSSV (Backup/Recover) Client

system ORCLdrvr           LSSV (Backup/Recover) Device Drivers

application ORCLman       LSSV (Backup/Recover) Man Pages

application ORCLnode      LSSV (Backup/Recover) Storage Node

application ORCLserv      LSSV (Backup/Recover) Server

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using Legato Single Server Version. For
more information, refer to the Legato Single Server Version Administrator’s Guide, Release
6.1.

Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.

Uninstalling Legato Single Server Version
Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Single Server Version for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Ensure that no Oracle backup or restore is running.
c. Enter the following commands to delete the required symbolic links:

$ cd $ORACLE_HOME/lib

$ rm liblsm.so

$ rm libobk.so

3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Single Server
Version daemons:

# nsr_shutdown
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5. Enter the following pkgrm command to uninstall Legato Single Server Version:

# pkgrm ORCLserv ORCLnode ORCLman ORCLdrvr ORCLclnt

At each prompt that pkgrm displays, press [Enter].

Note: The pkgrm program does not delete the /nsr directory containing the Legato
Single Server Version client index, media index, and resource configuration files.

6. To delete the Legato Single Server Version index and configuration files (an optional
step), enter the following rm command to delete the /nsr directory:

# rm -rf /nsr/* /nsr

Important: If the Legato Single Server Version index and configuration files (and the
/nsr directory) are deleted, existing Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.
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Chapter 6: Installation Procedures on Tru64 UNIX

This chapter describes how to upgrade to, install, and uninstall Legato Single Server
Version release 6.1 on a supported Tru64 UNIX system. See the appropriate section:

• "Upgrading from Legato Storage Manager" on page 35
• "Installing Legato Single Server Version" on page 36
• "Uninstalling Legato Single Server Version" on page 39

Upgrading from Legato Storage Manager
To upgrade from Legato Storage Manager to Legato Single Server Version:

1. Uninstall Legato Storage Manager. See "How to Uninstall Legato Storage
Manager" on page 35.

2. Install Legato Single Server Version. See "Installing Legato Single Server Version"
on page 36.

How to Uninstall Legato Storage Manager

Legato Storage Manager cannot be uninstalled using Oracle Installer. Legato Storage
Manager must be uninstalled using the information in this section.

Important: The following procedure deletes the Legato Storage Manager index and
configuration files (and the /nsr directory). After using this procedure, it will not be
possible to restore from existing Legato Storage Manager backups.

Legato Single Server Version does not support the restore of Oracle data from Legato
Storage Manager backups.

To uninstall Legato Storage Manager:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Storage Manager for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner
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b. Enter the following commands to delete the required symbolic links:
$ cd $ORACLE_HOME/lib

$ rm liblsm.so

$ rm libobk.so

3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Storage Manager
daemons:

# nsr_shutdown

5. Enter the following setld command to uninstall Legato Storage Manager:

# setld -d ORCLSERV550 ORCLNODE550 ORCLCLNT550 ORCLMAN550

Enter the appropriate information at the setld prompts:
• When prompted whether to continue, enter [y].
• When prompted whether to deinstall /usr/lib/X11/app-defaults/Networker,

enter [y].
• When prompted whether to delete the contents of the /nsr directory, enter [y].

Installing Legato Single Server Version
Legato Single Server Version is typically installed using Oracle Installer, by selecting
the Custom installation of the Oracle software and then selecting the Legato Single
Server Version option. If Legato Single Server Version is not installed using Oracle
Installer, the software can be installed manually using the instructions in this section.

Before installing Legato Single Server Version, uninstall any existing Legato Storage
Manager or Legato NetWorker software on the system. If existing Legato software is
not detected during the Legato Single Server Version installation, both the existing
Legato software and Legato Single Server Version might not function properly.

• To uninstall existing Legato Storage Manager release 5.5, see "Upgrading from
Legato Storage Manager" on page 35.

Note: To uninstall Legato Storage Manager prior to release 5.5, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.

How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Verify that there is sufficient disk space for each of the Legato Single Server Version
software components, as shown in Table 6 on page 37.

Note: The requirements in Table 6 on page 37 apply to a default Legato Single
Server Version installation, without relocation of the software components.
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2. Make copies of the following operating system files, which are modified by the
Legato Single Server Version installation script in step 6.

/etc/rpc

/etc/syslog.conf

3. Log in as the root user:

# su root

4. Insert and mount the Oracle9i release CD-ROM in the appropriate device.

5. From the CD-ROM mount point, go to the stage/Components/lgto directory.

Note: If the Legato Single Server Version software is not located in the
stage/Components/lgto directory, the directory containing the software can be
located by entering the following command from the CD-ROM mount point:

find . -name lsminst -print

6. Enter the following lsminst command to install Legato Single Server Version:

# ./lsminst .

Enter the appropriate information at the lsminst prompts:
• When prompted for a choice from the list of Legato Single Server Version

subsets, enter [5] to install all the subsets. Enter [y] when prompted if this
choice is correct.

• When prompted whether to create the /nsr/res/servers file, enter [y].
• When prompted whether the system is a member of a NetWorker cluster

server, enter [y] or [n], as appropriate.
• For all other lsminst prompts, press [Enter].

7. Update the MANPATH and PATH environment variables.

• MANPATH must include the pathname of the directory containing the
Legato Single Server Version man pages. The default pathname is
/usr/opt/networker/man, as shown in Table 6 on page 37.

• PATH must include the pathname of the directory containing the Legato
Single Server Version software binaries. The default pathname is
/usr/opt/networker/bin, as shown in Table 6 on page 37.

Table 6. Legato Single Server Version Requirements on Tru64 UNIX

Components Default Location Space Requirement

Software binary files /usr/opt/networker/bin 100 MB

Online index files /nsr 100 MB

Online man pages /usr/opt/networker/man 1 MB
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8. For each ORACLE_HOME that will use Legato Single Server Version for backups:

Note: If another ORACLE_HOME is later installed on the Tru64 UNIX system,
follow these steps to enable Legato Single Server Version backups for that
ORACLE_HOME.

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Change to the stage/Components/lgto directory on the CD-ROM.
c. Enter the following cp command to copy the liblsm.so file to the

$ORACLE_HOME/lib directory:
$ cp ./lib/liblsm.so $ORACLE_HOME/lib/liblsm.so

d. Enter the following commands to create the required symbolic link:
$ cd $ORACLE_HOME/lib

$ ln -s liblsm.so libobk.so

9. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. Select Server>Registration to open the Registration window.
– If "Legato Single Server Version" appears in the Registration window,

Legato Single Server Version is properly enabled.
– If "NetWorker/10 Eval" or another name (other than "Legato Single

Server Version") appears in the Registration window, perform these steps
to enable Legato Single Server Version:
1. In the Registration window, click Create.
2. In the Enabler Code field, enter the following enabler code:

fa577c-a16e3f-d26553

3. Click Apply.

The following command and output can be used to verify that Legato Single Server
Version is installed properly:

# setld -i | grep -i ORCL

ORCLCLNT610 installed Legato Single Server Version Basic Client

ORCLMAN610  installed Legato Single Server Version Man Pages

ORCLNODE610 installed Legato Single Server Version Driver and
Storage Node

ORCLSERV610 installed Legato Single Server Version Server

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using Legato Single Server Version. For
more information, refer to the Legato Single Server Version Administrator’s Guide, Release
6.1.

Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.
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Uninstalling Legato Single Server Version
Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Verify that no Oracle database backups are running.

2. For each ORACLE_HOME that uses Legato Single Server Version for backups:

a. Log in as the ORACLE_HOME owner:
# su ORACLE_HOME_owner

b. Ensure that no Oracle backup or restore is running.
c. Enter the following commands to delete the required symbolic links:

$ cd $ORACLE_HOME/lib

$ rm liblsm.so

$ rm libobk.so

3. Log in as the root user:

# su root

4. Enter the following nsr_shutdown command to stop the Legato Single Server
Version daemons:

# nsr_shutdown

5. Enter the following setld command to uninstall Legato Single Server Version:

# setld -d ORCLSERV610 ORCLNODE610 ORCLCLNT610 ORCLMAN610

Enter the appropriate information at the setld prompts:
• When prompted whether to continue, enter [y].
• When prompted whether to deinstall /usr/lib/X11/app-defaults/Networker,

enter [y].
• When prompted whether to delete the contents of the /nsr directory:

– Enter [n] to uninstall Legato Single Server Version without deleting the
index and configuration files.

– Enter [y] to uninstall Legato Single Server Version and delete the index
and configuration files (by deleting the /nsr directory).

Important: If the Legato Single Server Version index and configuration files (and the
/nsr directory) are deleted, existing Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.
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Chapter 7: Installation Procedures on Windows

This chapter describes how to upgrade to, install, and uninstall Legato Single Server
Version release 6.1 on a supported Windows system. See the appropriate section:

• To upgrade to, install, and uninstall the complete Legato Single Server Version
software package, see "Legato Single Server Version Installation Procedures" on
page 40.

• The upgrade to, install, and uninstall the Legato Single Server Version
Administrator program only, see "Legato Single Server Version Administrator
Program Installation Procedures" on page 45.

Legato Single Server Version Installation Procedures
This section describes how to upgrade to, install, and uninstall the complete Legato
Single Server Version software package (including the Administrator program) on a
Windows system.

Note: If Legato Single Server Version is installed using the instructions in this section,
the Administrator program does not need to be separately installed on the same
system.

For complete instructions, see the appropriate section:

• "Upgrading from Legato Storage Manager" on page 40
• "Installing Legato Single Server Version" on page 41
• "Uninstalling Legato Single Server Version" on page 44

Upgrading from Legato Storage Manager

To upgrade from Legato Storage Manager to Legato Single Server Version:

1. Uninstall Legato Storage Manager. See "How to Uninstall Legato Storage
Manager" on page 41.

2. Install Legato Single Server Version. See "Installing Legato Single Server Version"
on page 41.
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How to Uninstall Legato Storage Manager

Legato Storage Manager cannot be uninstalled using Oracle Installer. Legato Storage
Manager must be uninstalled using the information in this section.

Important: The following procedure deletes the Legato Storage Manager index and
configuration files (and the /nsr directory). After using this procedure, it will not be
possible to restore from existing Legato Storage Manager backups.

Legato Single Server Version does not support the restore of Oracle data from Legato
Storage Manager backups.

To uninstall Legato Storage Manager:

1. Log on as a member of the Administrators group of Windows.

2. Shut down all the Oracle instances, using SQL*Plus.

3. Stop all the Oracle database services, where the service names are of the form
OracleService<oracle_sid>.

• On Windows 2000:
a. Select Start>Programs>Administrative Tools>Services.
b. Select OracleService<oracle_sid> and select Action>Stop.
c. Click Close to exit the Services window.

• On Windows NT (Intel):
a. Select Start>Settings>Control Panel.
b. Select Services.
c. Select OracleService<oracle_sid> and select Stop.
d. Click Close to exit the Services window.

4. Select Start>Programs>NetWorker Group>Uninstall NetWorker.

5. Select Complete Removal to uninstall Legato Storage Manager and delete the
Legato Storage Manager index and configuration files.

Installing Legato Single Server Version

Before installing Legato Single Server Version, any existing Legato Storage Manager or
Legato NetWorker software on the system must be uninstalled. If existing Legato
software is not detected during the Legato Single Server Version installation, both the
existing Legato software and the Legato Single Server Version software might not
function properly.

• To uninstall existing Legato Storage Manager release 5.7, see "Upgrading from
Legato Storage Manager" on page 40.

Note: To uninstall Legato Storage Manager prior to release 5.7, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.
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How to Install Legato Single Server Version

To install Legato Single Server Version:

1. Log on as a member of the Administrators group of Windows.

2. Shut down all the Oracle instances, using SQL*Plus.

3. Stop all the Oracle database services, where the service names are of the form
OracleService<oracle_sid>.

• On Windows 2000:
a. Select Start>Programs>Administrative Tools>Services.
b. Select OracleService<oracle_sid> and select Action>Stop.
c. Click Close to exit the Services window.

• On Windows NT (Intel):
a. Select Start>Settings>Control Panel.
b. Select Services.
c. Select OracleService<oracle_sid> and select Stop.
d. Click Close to exit the Services window.

4. Insert the Oracle9i release CD-ROM in the CD-ROM drive. The Autorun window
appears.

If the Autorun window does not appear:
a. Start>Run.
b. Enter the following:

drive-letter:\autorun\autorun.exe

The Autorun window appears.

5. Choose Explore CD.

6. Navigate to the LGTO folder on the CD-ROM.

Important: Legato Single Server Version is installed in the C:\Program Files\nsr
directory by default. To install the software in a nondefault location, copy the entire
LGTO folder from the CD-ROM to the preferred drive and continue with step 7.

7. Extract the files from the lgto_62.exe self-extracting zip file. When prompted,
specify a directory in which to unzip the files.

8. If the software is being installed in a nondefault location, modify the server.iss file
in the LGTO folder. In the server.iss file, change:

Path=C:\Program Files\nsr\

to:
Path=drive:\pathname

Note: It is possible to change the drive name (from the default C:) or the directory
pathname (from the default \Program Files\nsr\) or both. The Path must end with
\nsr and must not contain any spaces. Save the updated server.iss file.
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9. Run the lsminst.exe program to install Legato Single Server Version.

10. Verify that the Legato Single Server Version services have started.

a. Open the Services window:
• On Windows NT (Intel):

1. Select Start>Settings>Control Panel.
2. Select Services.

• On Windows 2000, select Start>Programs>Administrative
Tools>Services.

b. Verify that the Status of the following services is Started:
NetWorker Backup and Recover Server

NetWorker Power Monitor (on Windows 2000 only)

NetWorker Remote Exec

11. Add the Legato Single Server Version installation directory to the system path:

a. Open the Control Panel.
b. Select System.
c. Select the Environment tab.
d. Select Path in the System Variables list box.
e. Add the complete pathname of the Legato Single Server Version installation

directory (preceded by a semicolon and ending in /bin) in the Value field. For
example:
;C:\Program Files\nsr\bin

Note: The semicolon (;) separates the new entry from existing entries. If Legato
Single Server Version was installed in a nondefault location, replace
C:\Program Files\nsr\bin above with the correct drive and pathname.

f. Click Set.
g. Click OK.
h. Restart the computer for the required changes to take effect.

12. Ensure that Legato Single Server Version is properly enabled.

a. Run the Legato Single Server Version Administrator program as an
Administrator.
For more information, refer to "The Administrator Program" in Chapter 2 of
the Legato Single Server Version Administrator’s Guide, Release 6.1.

b. In the Configure tab in the Server window, click Registration to open the
Registration window.
– If "Legato Single Server Version" appears under the Registration link in

the Registration window, Legato Single Server Version is properly
enabled.

– If "NetWorker/10 Eval" or another name (other than "Legato Single
Server Version") appears under the Registration link in the Registration
window, perform these steps to enable Legato Single Server Version:
1. In the Registration window, right-click the Registration link and

select Create to open the Create Registration dialog box.
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2. In the Create Registration window, enter the following enabler code
in the Enabler Code field:
fa577c-a16e3f-d26553

3. Click OK.

Once the software is installed, complete the required configuration procedures to
enable Oracle backup and restore operations using Legato Single Server Version. For
more information, refer to the Legato Single Server Version Administrator’s Guide, Release
6.1.

Note: Once Legato Single Server Version is properly installed and configured, it is
recommended that an immediate backup of the complete Oracle system be performed.

Uninstalling Legato Single Server Version

Before uninstalling Legato Single Server Version, ensure that a recent full backup of the
Legato Single Server Version client index (\nsr\index), media index (\nsr\mm), and
resource configuration files (\nsr\res) was performed.

Legato Single Server Version cannot be uninstalled using Oracle Installer. Legato Single
Server Version must be uninstalled using the information in this section.

To uninstall Legato Single Server Version:

1. Log on as a member of the Administrators group of Windows.

2. Shut down all the Oracle instances, using SQL*Plus.

3. Stop all the Oracle database services, where the service names are of the form
OracleService<oracle_sid>.

• On Windows 2000:
a. Select Start>Programs>Administrative Tools>Services.
b. Select OracleService<oracle_sid> and select Action>Stop.
c. Click Close to exit the Services window.

• On Windows NT (Intel):
a. Select Start>Settings>Control Panel.
b. Select Services.
c. Select OracleService<oracle_sid> and select Stop.
d. Click Close to exit the Services window.

4. Select Start>Programs>NetWorker Group>Uninstall NetWorker.

5. Select either Complete Removal or Partial Removal to uninstall Legato Single
Server Version.

• Complete Removal uninstalls Legato Single Server Version and deletes the
Legato Single Server Version index and configuration files.

• Partial Removal uninstalls Legato Single Server Version without deleting the
Legato Single Server Version index and configuration files.
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Important: Select Complete Removal only to delete the Legato Single Server Version
client index, media index, and resource configuration files. If the index and
configuration files are deleted, Legato Single Server Version backups cannot be
restored. If Legato Single Server Version is later reinstalled, the configuration must be
rebuilt before previous Legato Single Server Version backups can be restored.

6. If Partial Removal was selected in step 5, delete the nsr\bin directory manually. For
example, if Legato Single Server Version was installed in the default directory,
delete the C:\Program Files\nsr\bin directory.

Legato Single Server Version Administrator Program
Installation Procedures

This section describes how to upgrade to, install, and uninstall the Legato Single Server
Version Administrator program only on a Windows system that is separate from the
Oracle Server host containing the complete Legato Single Server Version software.

Note: The Windows system where the Administrator program is installed does not
need to contain Oracle Server software.

For complete instructions, see the appropriate section:

• "Upgrading from the Legato Storage Manager Administrator Program" on
page 45

• "Installing the Legato Single Server Version Administrator Program" on page 46
• "Uninstalling the Legato Single Server Version Administrator Program" on

page 47

Upgrading from the Legato Storage Manager Administrator Program

To upgrade from the Legato Storage Manager Administrator program to the Legato
Single Server Version Administrator program:

1. Uninstall the Legato Storage Manager Administrator program. See "How to
Uninstall the Legato Storage Manager Administrator Program" on page 45.

2. Install the Legato Single Server Version Administrator program. See "Installing the
Legato Single Server Version Administrator Program" on page 46.

How to Uninstall the Legato Storage Manager Administrator Program

The Legato Storage Manager Administrator program cannot be uninstalled using
Oracle Installer. Uninstall the program using the information in this section.

To uninstall the Legato Storage Manager Administrator program:

1. Log on as a member of the Administrators group of Windows.

2. Shut down all the Oracle instances, using SQL*Plus.
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3. Stop all the Oracle database services, where the service names are of the form
OracleService<oracle_sid>.

• On Windows 2000:
a. Select Start>Programs>Administrative Tools>Services.
b. Select OracleService<oracle_sid> and select Action>Stop.
c. Click Close to exit the Services window.

• On Windows NT (Intel):
a. Select Start>Settings>Control Panel.
b. Select Services.
c. Select OracleService<oracle_sid> and select Stop.
d. Click Close to exit the Services window.

4. Select Start>Programs>NetWorker Group>Uninstall NetWorker.

5. In the Uninstall NetWorker window, select Complete as the uninstall option and
click OK.

6. When a message appears stating that the client has been deleted successfully, click
OK.

Installing the Legato Single Server Version Administrator Program

Before installing the Legato Single Server Version Administrator program, uninstall
any existing Legato Storage Manager or Legato NetWorker software on the system. If
existing Legato software is not detected during the Administrator program
installation, both the existing Legato software and the Legato Single Server Version
software might not function properly.

• To uninstall existing Legato Storage Manager release 5.7, see the appropriate
section:
– "Upgrading from Legato Storage Manager" on page 40
– "Upgrading from the Legato Storage Manager Administrator Program" on

page 45

Note: To uninstall Legato Storage Manager prior to release 5.7, refer to the Legato
Storage Manager uninstall instructions in the appropriate Oracle Installation Guide.

• To uninstall existing Legato NetWorker software, refer to the instructions in the
appropriate Legato NetWorker Installation Guide.

How to Install the Legato Single Server Version Administrator Program

To install the Legato Single Server Version Administrator program:

1. Log on as a member of the Administrators group of Windows.

2. Insert the Oracle9i release CD-ROM in the CD-ROM drive. The Autorun window
appears.
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If the Autorun window does not appear:
a. Start>Run.
b. Enter the following:

drive-letter:\autorun\autorun.exe

The Autorun window appears.

3. Choose Explore CD.

4. Navigate to the LGTO folder on the CD-ROM.

5. Extract the files from the lgto_62.exe self-extracting zip file. When prompted,
specify a directory in which to unzip the files.

6. Run the setup.exe program to install the Legato Single Server Version
Administrator program software.

7. In the Setup Options window, select Client Only and click Next.

8. In the Choose Destination Directory window:

• To accept the default directory, C:\Program Files\nsr, for the installation, click
Next.

• To choose a nondefault directory for the installation, click Browse and select
the desired directory.

9. In the Authorize NetWorker Servers window, leave the field blank and click Next.

10. When a message box appears stating that the software has been installed
successfully, click OK.

11.Verify that the required Legato Single Server Version services have started.

a. Open the Services window:
• On Windows NT (Intel):

1. Select Start>Settings>Control Panel.
2. Select Services.

• On Windows 2000, select Start>Programs>Administrative
Tools>Services.

b. Verify that the Status of the following services is Started:
NetWorker Power Monitor (on Windows 2000 only)

NetWorker Remote Exec

For more information on how to use the Legato Single Server Version Administrator
program, refer to the Legato Single Server Version Administrator’s Guide, Release 6.1.

Uninstalling the Legato Single Server Version Administrator Program

The Legato Single Server Version Administrator program cannot be uninstalled using
Oracle Installer.

To uninstall the Legato Single Server Version Administrator program, follow the
procedure used to uninstall the Legato Storage Manager Administrator program, as
described in "How to Uninstall the Legato Storage Manager Administrator Program"
on page 45.


	Contents
	Preface
	Audience
	Product Documentation
	Conventions
	Information and Services
	General Information
	Technical Support
	Licensing and Registration

	Customer Feedback

	Chapter�1:� Introduction
	Installation and Configuration Options

	Chapter�2:� Installation Procedures on AIX
	Upgrading from Legato Storage Manager
	How to Uninstall Legato Storage Manager

	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Chapter�3:� Installation Procedures on HP-UX
	Upgrading from Legato Storage Manager
	How to Uninstall Legato Storage Manager

	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Chapter�4:� Installation Procedures on Linux
	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Chapter�5:� Installation Procedures on Solaris
	Upgrading from Legato Storage Manager
	How to Uninstall Legato Storage Manager

	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Chapter�6:� Installation Procedures on Tru64 UNIX
	Upgrading from Legato Storage Manager
	How to Uninstall Legato Storage Manager

	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Chapter�7:� Installation Procedures on Windows
	Legato Single Server Version Installation Procedures
	Upgrading from Legato Storage Manager
	How to Uninstall Legato Storage Manager

	Installing Legato Single Server Version
	How to Install Legato Single Server Version

	Uninstalling Legato Single Server Version

	Legato Single Server Version Administrator Program Installation Procedures
	Upgrading from the Legato Storage Manager Administrator Program
	How to Uninstall the Legato Storage Manager Administrator Program

	Installing the Legato Single Server Version Administrator Program
	How to Install the Legato Single Server Version Administrator Program

	Uninstalling the Legato Single Server Version Administrator Program



